GZIP compression not working on Multisite

Hi,

I am getting the following error message after activating the compression on Hummingbird. I also tried copy pasting the GZIP compression code into the htaccess file. Same error code.

Trying to improve JS and CSS but I won't get it enabled with Hummingbird..

gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

I am using a multisite in three languages and i have already tried improving js and css compression with different plugin such as autoptimize, super cache, w3 total cache (doesnt work on multisites) . So far no luck...

Anybody can help me out with optimizing pagespeed?

thanks

  • Hiram
    • New Recruit

    Hi Jude,

    thanks for the quick response.

    Does that mean, that the pagespeed score of 14/100 is also not accurate? It tells me that compression is on 48/100 and images on 60/100, the rest is almost 100/100. How can my score be so low then?

    I checked on other page speed sites and the score of http://www.hiram.de is almost everywhere below 30/100 with nearly 0 s of page load time, is that also due to the loopbacks? The subdomains en.hiram.de (english) and fr.hiram.de (french) seem to work better and faster.

    thanks in advance.

  • Rupok
    • Support Ninja

    Hi Hiram,

    Does that mean, that the pagespeed score of 14/100 is also not accurate?

    Thanks a lot for granting Support Access. I ran a scan on your site and also on Google PageSpeed Insight Tool. Result is same in both place: https://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fhiram.de

    So I don't think score is not accurate. Let's try to improve this.

    I went to your "Dashboard > Hummingbird > GZip Compression" section and found that GZip is only enabled for HTML on your site. You need to have GZip compression enabled for CSS and JS too. As a quick workaround, can you please click on the "Want to do it manually?" link on the right side box on Hummingbird GZip settings page? That will give you full details regarding how you can manually enable GZip compression for all type assets on your server. I'm giving you a screenshot of that section:

    I believe, this will help you in activating GZip compression for your CSS and JS assets too and that will help you in making your total score higher.

    If it doesn't help, can you please ask your host to check if in their server configuration if gzip is enabled for JS and CSS filetype too? Please let us know what they say about this and the result of your manually trying to enable GZip.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.