GZIP compression not working using Hummingbirg

Hi guys,
I tried to activate GZIP compression through the Hummingbird plugin. It seems that the missing JS GZIP compression the site gets quite slow :wink:.
Activation in the .htaccess file works so far, but I get the error, that the activation itself did not work.
I checked for the mod_deflate to be on (as using plesk I can easily activate these ) and it was active. Restarting apache did not help.
And I'm not sure if and which other plugin would interfere here.

Any ideas? :slight_smile:
Thanks and best regards,
Christoph

  • Rupok

    Hi Christoph, hope you had a wonderful day.

    It seems that the missing JS GZIP compression the site gets quite slow. Activation in the .htaccess file works so far, but I get the error, that the activation itself did not work

    Well, it's pretty tough to conclude something about this without seeing the issue live on your site. Can you give us any comparison of loading time of both GZIP enabled state and GZIP disabled state as you said GZIP is slowing down your site? I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. I could try to enable it myself and check the result. I could also check mod_deflate state. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • Christoph

    Hi Rupok,
    sorry, my statement was a bit unclear :wink: What I meant is: I wanted to activate GZIP compression for JS as I have the feeling the site is slow because the compression is not enabled right now :wink:.

    The issue itself is, that it is not possible to enable.

    I just granted the support access for the site, so you could get onto it and do what you heroes do :smiley:

    Thanks,
    Christoph

  • Nithin

    Hi Christoph,

    Hope you are doing good today. :slight_smile:

    I did a plugin/theme conflict test, but it didn't resolve your issue, and there doesn't seem to be a conflict. This brings back to the question of mod_deflate? Could you please confirm with your host whether it's running. Maybe it's installed, but not active?

    You can check this link for more details: http://kb.odin.com/en/126997

    If mod_deflate is still running, would you please send us your credentials so that we can have a closer look?

    You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Christoph,

    Hope you are doing good today. :slight_smile:

    Thank you for sending the credentials, but I'm not able to access your network admin nor the plugins menu, as the username 'wpmudev' created doesn't seem to have permission. Could you please look into it, as Hummingbird is only accessible through network admin. Maybe a plugin is causing this behavior.

    Please let us know once you make those changes, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Christoph,

    Hope you are doing good today. :slight_smile:

    I checked your website, and on further investigating, it seems like Plesk is running a combination of Apache, and NGINX together. Is this the default behavior that you have configured?, can you please check this and confirm?

    Hummingbird currently doesn't seems to work in this configuration, as the plugin is detecting it as nginx server. If you think you can consider using only the Apache configuration, If possible, could you please check whether there is an option to turn off nginx in your Plesk environment, under: Tools & Settings > Services Management, and stop the Reverse Proxy Server (nginx) service.

    Changing this should clear the gzip compression error. I hope this helps. Please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Sylvio

    Hi there.
    I had exactly the same experiment. Thanks for the tricks...
    But I have an important question to add :
    Is the nginx as revers proxy not useful for the site performances ?

    Is there a gain to disable it to be able to enable all features of hummingbird ?
    Does anybody made a benchmark with see ?
    As I figure the situation, the best would be to have hummingbird compatible with the plesk original setup it means using PHP as FastCGI behind a Nginx reverse proxy ?

    The other con of your solution is that we need to disable Nginx for the whole Plesk server and no other subscriptions on this server will be able to use Nginx as FPM application...

  • Nithin

    Hi Sylvio,

    Hope you are doing good today. :slight_smile:

    I'm afraid there isn't any benchmark available related to Plesk for Hummirgbird. Hummingbird is meant to help optimize your site, other than minification, you won't be able to make use of features like Gzip, browser caching through Hummingbird.

    You'll have to set these up manually in your system:
    https://iserversupport.com/enable-compression-leverage-browser-caching-plesk-apache-nginx/

    Setting up NGINX proxy will help improve sites performance for your users in a Plesk environment. However, the solution provided above is more of a workaround, only if you are looking to make use of Apache. At the moment, I'm afraid, Hummigbird is not compatible with Plesk, and if you aren't making use of NGINX, the workaround would be to disable NGINX proxy. This would come with the con what you have mentioned, so the above solution isn't meant for users who makes full use of a Plesk, and it's environment.

    The developers are aware of this issue, but at the moment, I don't have an exact ETA on when a compatible version for Plesk will be made available. Will definitely keep you posted once we have an update regarding this. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.