gZip compression on https (SSL) site not working

Hello
I am having problems with my site running slow and am working through the recommendations as per the Hummingbird tests. Today I received this notification:
--------
gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration

If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.
--------
I contacted my domain host and they have informed me that Apache is enabled and gZip is working on my site, however as my site has an SSL certificate and I am hosted with a shared host that the GZip will not work as it would create security issues for my site.

Can someone please get back to me with a workaround for this? My site is receiving a 32/ 100 score and I really want to start marketing, but with a page load speed of 21.2 seconds, it would be a waste of money to start any marketing yet.
I look forward to your response
Thankyou
Tiecia

  • Sajid

    Hello Tiecia,
    Hope you are doing good today :slight_smile:

    One of my colleague Dimitris have GZIP configured on two of his site, both are over HTTPS and he had no issues. He acquired SSL certificates from letsencrypt.org for both of his sites.

    From where did you get the SSL certificae and what kind of security issues you are suspecting ?

    To enable the GZIP on your site please also try below options and see if you could get it enabled.

    The message suggests that the "mod_deflate" module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":

    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may need to contact your hosting provider for these steps but I hope it'll fix the issue.

    Yes, I agree that with this much of speed it will not be a good idea to spend money on marketing. However, if your site score is 32, then I don't think it is all just because of GZIP configuratin.

    Did you tried other performance improvements like optimizing images, enabling minification and eliminating render blocking, using object cache to improve the server response time and enabling browser cache along.

    If no then please try other options too and I am sure these will help improve the site performance score.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Tiecia

    Thankyou Sajid! You are extremely helpful.

    Does your friend have a dedicated host or a shared host? My host (Crazy Domains) said that the GZIP compression with an SSL certificate would work on a dedicated host, but as they provide shared hosting it would create security issues.

    I purchased the SSL certificate through my host as I had heard that google would prioritse https sites in SEO. I have the PayPal plugin on my site that I use for purchases. Personally, a few weeks ago, I made a PayPal transaction using my credit card, and never received the product. Upon investigation the transaction was intercepted between the site I made the purchase on, and me using my credit card on PayPal, so I know that there needs to be extra security there.

    I will ask the host to check the coding that you have suggested, again, thank-you : )

    I joined WPMUDEV as my website has always been extremely slow, and I find all of the WPMUDEV plugins to be really helpful, so yes I have tried other performance improvements like optimizing images, and eliminating render blocking.

    I am yet to enabling minification, use object cache to improve the server response time and enabling browser cache along.

    Whist I think I can do the minimification, can you please tell me how to use object cache to improve the server response time and enabling browser cache along?

    My site was with another host, but I recently moved it as it was in a managed wordpress environment. In that environment I was not able to do any caching, so I am not familiar with how to go about this. I have installed WP Super Cache which is great. I am thinking of joining up a CDN, but again, while the site is so slow I would be wasting my money on advertising.

    You are awesome.
    Thankyou
    Tiecia

  • Sajid

    Hello Tiecia,
    Hope you are doing good today :slight_smile:

    My colleague has hosted one of his site on shared hosting environment on site ground and the other one is on a droplet using the Cloudways.

    To configure the WP Super cache please see the following step by step guide of installation and configuration.
    http://ideaboxthemes.com/setup-wp-super-cache/

    Enabling the bowser cache is a click of a button like the GZIP configuration and yes if your host support it.

    To enable it go to Dashboard -> Hummingbird -> Browser Cache -> Enable Caching and click on the ENABLE CACHING big yellow button to automatically it or follow the steps to enable it.

    Also, please, if you have any further questions then create a separate support ticket for each one of those questions. This will really help us manage each issue in its own ticket and would definitely help other members find an answer quickly looking for same issue.

    Thank you and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.