GZIP Compression Stopped Working

I went into my site today and was reviewing settings and the GZIP is no longer working. This was after the Uptime Monitor was just fixed. I am not sure if they are due to a similar issue. Any help would be appreciated.

  • Nazmul H. Rupok

    Hi there,

    Hope you are doing well today. Sorry to hear that you are having trouble. We can check your setup and suggest you the best workaround. Would you mind allowing support access so we can have a closer look at this on your end?
    To enable support access you can follow this guide here:

    Please respond in this thread once access is granted.

    Best regards,

  • Nazmul H. Rupok

    Hi there,

    Hope you are doing great today. Thanks for granting the access. I have checked your setup and looks like the "deflate" module was not enabled on host which might causing the issue. Can you make sure with your Webhost to see if "deflate" module is enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).

    Also, if you could try de-activating all other plugins except Hummingbird and see if it works then so we can eliminate a plugin conflict.

    Let us know how it goes.

    Have a nice day. Cheers!

  • Predrag Dubajic

    Hi Stephen,

    Can you check your .htaccess file, the one in root WP folder, and see if you have this code in there:

    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz

    If the code is there then we need to check why the server doesn't pick up on it and doesn't apply compression rules.
    Can you check with your host if "mod_deflate" is still enabled on your site as this is required for GZIP compression to work?

    If the module is indeed enabled then it could be that the GoDaddy doesn't allow this change to be made from .htaccess file and that they are using predefined values, so if mod_deflate is enabled please check with them about this as well and let us know of their response.

    Best regards,