gzip html compression not working

I’ve just activated hummingbird om this site but html compression does not work -apparently there’s a problem with mod deflate. The host thinks all’s ok.. Any suggestions? Thanks – the site is reeeeeallllyyy sllllooowwww..:wink:

  • Adam Czajczyk
    • Support Gorilla

    Hello joost_de_boer

    I hope you’re well today!

    I checked the site from outside an it actually looks like gzip compression is working. In fact: JS and CSS files are served from WPMU DEV cloud and the compression is applied there but there are also proper HTTP headers returned by the server for other resources – so it seems to be fine.

    Sometimes such “false alarm” message shows up if either the server configuration is “set in stone” and cannot be changed by the plugin (as gzip compression is performed by the server) or the plugin is not able to write to .htaccess. Often it’s sufficient to wait a while and just re-check compression in Hummingbird settings. If there’s any server-side cache it’s also good to clean it up before re-checking.

    If that doesn’t change the “not working” message, there might also be a different reason for this. In that case, I’d like o take a closer look at your setup so would you please enable support access to it for me?

    To do so, please go to the “WPMU DEV -> Support” page in your site’s back-end and click on “Grant support access” button there, then let me know here once it’s done.

    As for the site performance in general. Gzip compression is a nice tool but it won’t make very huge difference and if the site is under-performing there might be some other aspects that should be addressed. Once you enable access, I’ll be happy to take a look there to see if I can suggest any additional changes/actions that could possibly improve site’s speed.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello joost_de_boer

    I hope you’re fine today!

    I apologize for such a long overdue. Since you never responded to my previous post here, the I lost the ticket from my sight and assumed you don’t require any further assistance. My colleagues informed me though that you have asked them via Live Chat about the issue and that you passed access credentials to us.

    Therefore I checked the site and server again and also asked one of Hummingbird developers to check it to. The the compression is actually active and the issue here is, as I suspected, that the Hummingbird simply cannot detect whether HTML compression is on or off.

    I double-checked the compression rules in .htaccess and they are fine. There’s no plugins that could block such check either and the site itself responds with HTTP status “200 OK” to requests, including trying to fetch it directly via curl. So that’s fine too.

    Yet, the message in compression settings says that “privacy mode” was detected so Hummingbird cannot properly test compression. The “Privacy Mode” means that when requested, the site returns “401” HTTP status in header and “401” status means “Unahtorized”. It would be the case, for example, if the site was protected with HTTP auth (browser login) – but it is not. It’s not in maintenance mode either.

    This would mean that most likely something on the server is blocking this “check”. The host is right about site being properly configured for gzip compression so the only thing that needs sorting out is that compression check. Unfortunately, apparently I don’t have access to any server logs via FTP so I can’t investigate it there too.

    That being said, could you please turn to your host and ask them if they could check server’s access/error logs for any “self requests” resulting in “401” status? If there are any – what would be these specific requests?

    Let me know about their response, please.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.