Gzip HTML not working

HI! I'm getting this error:

gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

But my host confirms that the server should be setup properly, and asked me to show you this:
rootelenanik [~]# httpd -M | grep deflate
deflate_module (static)
rootelenanik [~]# php -i | grep gzip
gzip compression => enabled
rootelenanik [~]# hostname
host.newmemberwebsites.com

Ideas?

  • Nithin

    Hey William,

    Hope you are doing good today.

    Please make sure that clicking the Re-Check Expiry button makes any difference?

    If that didn't work, maybe the zlib library isn't configured? Could you please check whether adding the following code in your php.ini file helps, or not.

    zlib.output_compression = On

    If not present, you'll have to create php.ini in your root folder, ie the folder where wp-config.php file resides.

    Please do let us know how that goes, and enable support access, if you still have issues, so that we could have a better idea about this. Have a nice day ahead.

    Best Regards,
    Nithin