gzip is enabled, but other service sites saying it's not

gzip is enabled using hummingbird, and HB says it's enabled. But other sites saying it's not enabled. Like:
https://developers.google.com/speed/pagespeed/insights/?url=www.j****mation.co.uk&tab=desktop
https://gtmetrix.com/reports***mation.co.uk/pEZI4Smu
https://checkgzipcompression.com/?url=http%3A%2F%2Fwww.***mation.co.uk

  • Aidan

    This is the reply from my host:

    Thank you for contacting the Fasthosts Support Team.

    Below is a summary of your request and our response.
    Your Ticket Summary
    Subject
    Plugin Issue- GZIP

    Response By Email (Luke) (12/12/2017 09.23 PM)
    Dear Aidan

    Thank you for contacting us.

    We have heard back from our second line engineers who have confirmed that zlib output compression is enabled on the server.

    I have provided some information from the server about this below incase it useful to pass on to the developers:

    ZLib Support enabled
    Stream Wrapper compress.zlib://
    Stream Filter zlib.inflate, zlib.deflate
    Compiled Version 1.2.7
    Linked Version 1.2.7

    Best regards,

    Luke
    Fasthosts Customer Support
    Customer By CSS Email (Aidan Kirkpatrick) (12/12/2017 02.02 PM)
    Hi Bilal,

    My wordpress website jamesautomation.co.uk was running slowly so I installed a plugin from wpmu-dev on it. WPMUDEV have a plugin called Hummingbird that optimises and speeds up websites. On it there is an option to enable GZIP compression. According to Humminbird, GZIP Compression is enabled, but according to GTMetrix (and Pingdom) it is not. I have asked the developers at WPMUDEV to take a look into this, which they have and their latest comment was “Can you ask your host to enable zlib output compression and check the results after that?”.

    That is where we are now.

    Please let me know if you need anything else.

    Kind regards,

    Aidan

    Response By Email (Bilal) (12/12/2017 01.43 PM)
    Hi Aidan,

    I hope you are well,

    Please reply to this with as much information as possible.

    Thanks

    Bilal
    Fasthosts Frontline Support
    Question Reference # 171212-000521
    • Date Created: 12/12/2017 01.43 PM
    • Date Last Updated: 12/12/2017 09.23 PM
    • Status: Waiting on Customer
    What Next?
    If this answers your question to your satisfaction you do not need to take any action. This ticket will automatically close in 7 days.
    If you would like further information, or if this does not address your concerns, please click here to update your question.
    Kind Regards,

    Fasthosts Support Team

  • Adam Czajczyk

    Hello Aidan,

    Thank you for your response.

    I run a number of additional tests on your site and I can confirm that the JS and CSS files are properly compressed. However, the homepage (but also other pages) - which is the only page checked by PageSpeed Insights or GMetrix - is not. I manually checked other pages on site and the result was the same: JS and CSS resources there were compressed but not the page itself.

    In fact, that means that "text/html" MIME type is not compressed properly (so that'd be a server issue) or wrong headers are served (which would mean that either the theme or some other plugin is interfering here or there's some sort of error/glitch in configuration added by/taken from Hummingbird).

    I understand that when you check compression in Hummingibird, it shows that all three types of content are compressed (HTML, JavaScript and CSS), correct?

    Could you reach out to your host once again and just make sure that this specific MIME type is allowed to be compressed: "text/html"? Also, could you please enable support access to your site so we could take a closer look at the setup? You can do it on "WPMU DEV -> Support" page in your site's wp-admin area.

    Last but not least, when I'm checking the site from outside an nginx webserver is detected. Can you confirm (or double-check with your host) that it's nginx solely powering your site or if it's nginx that's in front of Apache (which is actually more and more common type of setup)?

    Best regards,
    Adam

  • Aidan

    Hi Adam,

    Reply from FastHosts:

    *************************************************
    Dear Aidan

    Thank you for contacting us.

    Our webservers run Nginx as a reverse proxy sitting on top of apache which is the reason for the incorrect information being relayed on some page speed testers , your developers will be able to set the type of compression for the different files, we allow those MIME types to be compressed on our web servers.

    Best regards,

    George
    Fasthosts Customer Support
    *************************************************

    Does this help?

    Regards,

    Aidan

  • Predrag Dubajic

    Hi Aidan,

    That actually explains what's going on, the compression is enabled for your files as already mentioned before, but your server setup is causing some of the speed test tools not to see this properly and will show incorrect results.

    So the files are compressed properly but the test tools are unable to get the correct status due to your server running Nginx reverse proxy on top of apache.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Aidan,

    This is not something that can be fixed from Hummingbird, and it's not actually an issue, your files are compressed and served as such to your visitors, but due to your server configuration the results are incorrect, so even if you do get correct result in there it will not improve your page load speed.

    To improve your page load speed you should look into resolving other issues, like large images and file minification.

    For large images you should check your images used in "Latest Projects" section.
    In there your images are 1024x768 while the actual image holder is only 360x270.
    You should check this with theme developers in order to call smaller images in that section so that they match the wrapper size.

    And for file minification you can enabled Hummingbird minification and in there tweak the settings so that most of your files are minified, combined, and moved to load from footer but without breaking any site functionality.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Aidan!

    The "advanced-cache.php" file is a special WordPress "drop-in" file that's used to "signal" cache usage. It doesn't exist on fresh installs but most of caching plugins are adding it.

    If you have ever used any caching plugin on your site (for example: W3 Total Cache, WP Super Cache etc), they would create that file. While Hummingbird didn't provide a full-page cache until just recently, it didn't check it. However, now, as it can also perform full caching, it does that in order to avoid conflicts - there should never be two "full page" caching tools run at once on the same site

    The bottom line is: if you are using a cache plugin like W3 Total Cache or similar, you'd want to either switch it off and remove the advanced-cache.php file and then enable Page Caching in Hummingibird or to stick to that plugin that you're currently using and not use Hummingibird's cache.

    If you're not using any caching plugin yet (except for Hummingibird) and this file is still detected, you might want to remove it (but please make a copy of it first so you could restore it in case it broke the site) as often such file is a "leftover" after testing some other caching plugins.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.