gzip is not working properly


I'm getting a "gzip is not working properly" when trying to enable compression. The .htaccess file is group-writable (and in fact does have the humming bird section). I checked with my hosting provider and they said mod_deflate is enabled. In the panel, it says that only html compression is not enabled.



  • Predrag Dubajic

    Hey Álvaro,

    Hope you're doing well today :slight_smile:

    Can you please check if the .htaccess has correct rules added.

    Access your WP installation via FTP or cPanel and open .htaccess file, then go to Hummingbird > GZIP Compression and on right side click Want to do it manually? link, it will expand rules that are needed in .htaccess so compare that with your current rules and make sure everything is there.

    Note: if you do any changes to .htaccess file make sure to have backup ready first.

    Let us know how it goes.

    Best regards,

  • aldelval

    Hi Predarg,

    Thanks for your reply. As I said in my message, the .htaccess file has a humming bird section, written by the plugin, not by me. Checking now in more detail, that section matches exactly what is shown by the "want to do it manually?" link.

    Still unable to get text/html compression enabled (text/css and text/js *are* enabled), and getting the same message about gzip not working properly.

    I granted you access to the site through the plugin, if you want to look at it.





  • Milan

    Hey Álvaro

    Hope you are well today and won't mind me chiming here. :slight_smile:

    Could you please attach your site's .htaccess file here ? Just rename it to some other name and give it a ".txt" extension. ( Our forum is not accepting sensitive file formats ) You can attach files by attach file function of reply box. Take a look at this screenshot. :slight_smile:

    Look forward to hearing back. :slight_smile: