Gzip is not working properly

gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
---
Here's the response from iPage (our web hosting provider):
---
I have enabled mod_deflate by adding code 'SetOutputFilter DEFLAT' in .htaccess. I have also added gzip compression code in .htaccess still in website admin page it shows not enabled, You can try disabling other plugins one bye one, if still not working contact your plugin vendor of WP Hummingbird and check further.
---
I have disabled all plugins except WP Hummingbird and WPMU DEV Dashboard and am still receiving the same error.

Can you please assist? Many thanks.

  • Dimitris

    Hey there Robert,

    I trust you're doing good today and thanks for reaching us! :slight_smile:

    Could you please double check that there're the appropriate lines in your .htaccess file?

    Sharing with us your .htaccess file it would be even better. Just download it via FTP, rename it like htaccess.txt and attach it here in your next reply.

    The message suggests that the "mod_deflate" module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":

    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may need to contact your hosting provider for these steps but I hope it'll fix the issue.

    Warm regards,
    Dimitris

  • Dimitris

    Hey there Robert,

    thanks for sharing your .htaccess file, I was able to confirm that HummingBird additions are in place.

    Did you have any feedback from your hosting provider considering the remaining points of my previous reply?

    Could you please access your server via FTP and create a info.php file in the root folder of your WP installation with the following content?
    <?php phpinfo(); ?>
    By doing do we should be able to check all of the PHP settings and modules by visiting your_domain.com/info.php.

    Warm regards,
    Dimitris

  • Predrag Dubajic

    Hi Bob,

    Thanks for that, based on the info file it does indeed seem that deflate module is enabled, however it seems that it's not the HB that's not picking up the changes made in .htaccess file, google page speed test doesn't see it as well.

    Some hosting providers don't actually allow these changes to be applied from .htaccess so could you get in touch with your hosting provider again and see if they allow these changes?

    P.S. Once this issue is resolved it's highly suggested to delete info.php file.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.