gzip is not working properly

I got this error message when enabling the gzip compression. Can you help me with my next step ?

gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration

  • Majid
    • Recruit

    Hello Jill !

    I hope you are having a nice day :slight_smile:
    Can you please try performing a plugin conflict test by deactivating all the other plugins except for HummingBird and WPMU DEV dashboard plugins.

    After doing that please recheck the gzip compression if it's working.
    If this didn't help, please make sure you enable the support access for us to check.

    You can do that following this guide :
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Majid

  • Majid
    • Recruit

    Hello Jill ,

    I checked the backend of your site and I could see that the HTML compression is enabled however the JS/CSS are not. this could be something coming from your hosting provider where they only allow compression for HTML.

    I suggest contacting them, asking them to allow the compress for all the other file types.
    In case they confirm it's enabled, please make sure you send us some extra info to check further.

    You can send credentials by using our secure contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: *Majid Hamdani*”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Regards,
    Majid

  • Majid
    • Recruit

    Hey Jill,

    Sorry for the delayed response, I checked the .htaccess file and seems like the Compression rules are already added by the plugin. But still the other two file types are not enabled, which indicates that their compression might have been disabled by your hosting provider. I suggest contacting them and asking them to check if JS and CSS GZip compression is enabled.

    Let us know what they confirm.
    Cheers,
    Majid

  • Jill
    • WPMU DEV Initiate

    Hi Majid,
    I checked with the hosting company and they replied with the following.
    Im not sure what the next step is ?
    Thanks in advance
    PS Also just to say for security Ive removed my url below and replaced it with mydomain)

    "We don't specifically enable/disable compression for any file type.
    It is entirely controlled from your side via the .htaccess file that can be written by you (or sometimes directly by your CMS).
    So you may need to check the contents of that file and check if it includes any specific file types that you need.
    Don't forget to sync the .htaccess file across the cluster after making any changes (Websites -> mydomain.ie -> Web Hosting Settings -> Sync .htaccess) to ensure they take effect immediately "

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.