gzip is not working properly

Hi everyone,

I keep having trouble with Hummingbird and GZIP-compression. I already had to move the .htaccess file from /wp-content to the root, and that seemed to help. But now I noticed that Hummingbird is acting up. Sometimes it shows the compression is on, sometimes off. And that without changing anything!

So I tested my site on gtmetrix.com and there it gave a big error on GZIP-compression. So I really would love to see that working. Anyways, I tried to add the code to my .htaccess manually, but I couldn't find any <directory> tag... And now I'm a bit unsure what to do.

Can you please have a look at it? I think it will be a bit of a complicated issue since the status switches between on and off (I think it is actually always off).

Support access granted !

kind regards,

Michaël

  • Nastia

    Hello Michael

    Hope you're doing well!

    The code that is added to .htacces file is required to enable the GZIP compression. Your server is running on Apache, so please make sure that the below code is added to the .htaccess file:

    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>

    If the code is not there, add at the top of existing rules in .htaccess file and then see if it works.

    If the code is there, please perform a test for a conflict with another plugin. Deactivate all other plugins and test if the GZIP is enabled. If everything is well, activate one plugin at a time to see
    if a plugin could block GZIP compression.

    Please let us know how it went!

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.