gzip is not working properly:

gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host

i have checked at the host level it enabled and working fine

what could be the reason

  • Milan

    Hello Rakesh

    Hope you are well today and thanks for asking us. :slight_smile:

    Can you please conduct a theme/plugin test to ensure that this is not some kind of conflict? You can find details in a nice flowchart here (just scroll down a bit) https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If this continues please double-check your server for following issues as well:

    - check if there's a Varnish cache running on server (or any other server-side caching solution); if it is, make sure to purge/empty its caches

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":

    zlib.output_compression = On

    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may want to contact your hosting provider for help with these but I hope it should fix the issue.

    Let me know how it goes. :slight_smile:
    Warm regards,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.