Gzip is not working properly:

Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

Java script and CSS are not working (show inactive).

Using SiteGround Cloud.

I tried this:
https://www.siteground.com/kb/how_to_enable_gzip_compression_for_your_pages/

No change.

I also went into cPanel and Optimize and chose "Compress All" but also no change.

  • Dimitris

    Hello there Logan,

    hope you're doing good today! :slight_smile:

    I have a little shared server from Siteground for testing purposes and GZIP can be enable from HummingBird settings. The following snippet is what's used in .htaccess file:

    # BEGIN WP-HUMMINGBIRD-GZIP
    
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>
    # END WP-HUMMINGBIRD-GZIP

    Could you please try to manually edit this file, remove any other rules for GZIP and insert the above ones after the default WP rules?
    In order to better test any other possible conflicts in there, you can also comment/remove temporarily and other lines, so you have a file like this (that's for a single WP installation):
    https://monosnap.com/file/TmsAHwcSwYYLrDR1CW0jgQIvZZHUrS
    Then go the GZIP page and click on the "Re-check status"
    https://monosnap.com/file/C4NbpbpJHUJlIsRuH8uYa052hmhQXk

    If that makes no difference, please proceed with a conflict test. Simply deactivate all other plugins apart from WPMUDEV Dashboard and HummingBird, activate a default theme like TwentySeventeen, "re-check status" in GZIP page and see how that goes. If it's shown as enabled, then start activating the remaining plugins and themes, one by one this time, checking each time the GZIP page ("recheck status" each time), until you find the plugin/theme causing that.
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Let us know how that goes! If you still can't make it work, or find any conflicts, please grant support access to this installation via WPMUDEV Dashboard plugin, as shown here
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5
    and let us know that you did so, as we don't get any notifications about it.

    I also went into cPanel and Optimize and chose "Compress All" but also no change.

    I didn't even know that setting in cPanel, thanks for pointing this out. It seems that my setting is still in default "Disabled" option.

    Warm regards,
    Dimitris

  • Logan

    Hello.

    That snippet was identical to what I have already in .htaccess, but I did notice it was AFTER the default Wordpress stuff.

    So I moved it above and all is well.

    The take away, then, would be why/how this happened.

    If it helps, I had WP Rocket installed/configured and deactivated it, and installed Hummingbird.

    Again, the issue was that the code snippet used for GZIP (the one posted on this thread), was BELOW the default WordPress items. I moved this from the top to the bottom and re-checked GZIP compressionand all green.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  • Nastia

    Hello Logan

    Hope you're doing well!

    Please run the following steps, deactivate all plugins except the hummingbird and check if the GZIP can be enabled. If all is well, please activate one plugin at the time, every time checking if the status is changed.

    Can you please check if on another site on the same server, have GZIP enabled?

    If the issues still persist, make sure that PHP is configured to support zlib library and that zlib output support is enabled; place this link to a php.ini file, in the /wp-admin/ folder

    zlib.output_compression = On

    Let us know how it went!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.