Gzip is not working properly

We are facing issue with Gzip and it is not working properly. It shows below error that shown it below screenshot:
https://drive.google.com/file/d/1dDV61MVXHA__1QBm9ujzG0hazn7RbyAF/view?usp=sharing
We have also communicated with server support team and Gzip is by default enabled on the server.

So, can you please look into this and help me to fix this issue. It is urgent and it effects on my website's performance.

Thanks in advance!!

  • Nastia

    Hello JP

    I trust you're doing well!

    Based on the screenshot, the compression is not enabled for HTML type. I've checked your site using online tool https://checkgzipcompression.com/ and GZIP compression for the HTML type is indeed enabled. Looks like there are some security level added on your server that is not allowing to Hummingbird to access the server information to check if this type of compression enabled or not.

    Please try adding the following line in your php.ini file, if the php.ini file is not there, feel free to create it.
    zlib.output_compression = On
    Re-check the GZIP Compression from Hummingbird end one more time after this and let us know if it is shown as enabled.

    Let us know how it went,

    Cheers,
    Nastia

  • JP

    Hello Nastia,

    I have contacted server support team to modify php.ini file and they replied me as below:

    "GZIP is enabled at nginx level. If they wanted an additional rule added though they need to provide that to us in nginx format and we may be able to add it then. we dont edit the php.ini file directly on any server. Alternatively they could provide you with the htaccess equivelant."

    So, can you please provide it in nginx format or htaccess equivelant code for the same ASAP.

    Thanks!!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.