gzip is not working properly + help required with minification settings

I have wpmudev components fully installed on http://www.japanesemountainretreat.com.au. I have also just added Cloudflare successfully. However, GZip is showing the following error:

gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration

Also, I'm not 100% sure how to take advantage of the Minification settings. I don't know if the way I've done it maximizes performance. Assistance with both of these ASAP would be greatly appreciated.

  • Huberson

    Hi Jon,
    To fix the error with gzip make sure you have deflate module for apache or ngx_http_gzip_module for nginx installed and enabled on your server.
    The easiest way to do that is to contact your hosting provider and request them to make the configuration.

    If you have ssh access to the server and prefer doing that on your own, use this command to check if deflate module is enabled on apache
    sudo apache2ctl -M
    and
    sudo a2enmod deflate
    to enable it if it's not.
    You can follow this guide for nginx - add gzip module to nginx

    In case the above options don't fix it, try adding this line in your php.ini file if you have access to it.
    zlib.output_compression = On

    Or place this snippet in your .htaccess file

    <ifModule mod_deflate.c>
    <FilesMatch "\.(css|js|x?html?|php)$">
    SetOutputFilter DEFLATE
    </FilesMatch>
    </ifModule>

    Also, I'm not 100% sure how to take advantage of the Minification settings. I don't know if the way I've done it maximizes performance.

    You can enable support access to the site and we'll take a look at that.