gzip is not working properly (Hummingbird)

Hi,

Our site uses Divi Theme from Elegant Themes and we've recently started to use your plugins. We attempted to enable gzip through Hummingbird but received the following message:
gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration

We are hosting with Heart Internet, the server information is:

Server Information
Server / Website IP Address: 10.0.1.46
Server Type: Apache/2.4.18 (Unix)
Operating System: Linux
Browser Compression Supported: gzip, deflate, sdch
PHP Process User (UID:GID): encoded.co.uk (106400:106446)

Any help you can offer is appreciated.

Kind regards,

Rob

PS
Here is a list of current plugs we have installed and their activation status.
== Listed Plugins ==
[ ] Akismet - Version 3.1.10
[ ] Cookie Control - Version 2.2
[a] Delightful Downloads - Version 1.6.4
[a] Diagnostic Glance - Version 0.9.2
[a] Diagnostic Tool - Version 1.0.7
[ ] dotmailer Sign-up Form - Version 3.4.2
[a] Duplicator - Version 1.1.6
[a] Elegant Themes Updater - Version 1.0
[a] Fast Secure Contact Form - Version 4.0.41
[a] Google Sitemap by BestWebSoft - Version 3.0.3
[ ] GZip Ninja Speed Compression - Version 1.2.3
[a] iThemes Security - Version 5.3.7
[a] LayerSlider WP - Version 5.6.7
[a] Logooos Wordpress plugin - Version 2.2
[ ] Lucky Orange | Chat, heatmaps, polls, visitor recordings, live analytics. - Version 1.94
[ ] NewStatPress - Version 1.2.1
[ ] WordPress HTTPS - Version 3.3.6
[a] WordPress Importer - Version 0.6.1
[a] WP Hummingbird - Version 1.2
[ ] WPJobBoard - Version 4.4.0
[a] WPMU DEV Dashboard - Version 4.0.9
[ ] WP Smush - Version 2.2.2
[a] WP Smush Pro - Version 2.2.2
[a] WP Super Cache - Version 1.4.8
[a] Yoast SEO Premium - Version 3.2.5
16 active plugins out of 25 present

  • Predrag Dubajic

    Hey Rob,

    Hope you're doing well today :slight_smile:

    Based on the server info it looks like required modules are active so it's quite possibly plugin conflict.
    Unfortunately we can't test all plugins out there with all setup combinations so you would need to perform troubleshooting yourself by disabling other plugins and see if you're able to active compression after that.

    Also, can you check your .htaccess file and see if mod_deflate are actually added there?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.