Gzip is not working well, HTML is inactive .

When I try to enable the Gzip it says, 1 of your compression types are inactive, when I apply the rules I got:

Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.

Can you help me?

  • Kasia Swiderska

    Hello Alfredo,

    I'm sorry to hear this is not working correctly on your site.

    I checked settings on your site and code in htaccess and php.ini are correct to enable gzip for HTML.
    I cleared cache and there was not change.

    In this case please contact GoDaddy and ask if they are allowing to enable gzip compression from htaccess level (on some servers it's blocked). And if they are not blocking it please ask why its not possible to enable it from htaccess.
    Let us know what they will say.

    kind regards,
    Kasia

  • Adam Czajczyk

    Hello Alfredo

    I have checked your site. Like Kasia already noticed, the compression rules in the .htaccess are correct. The required Apache modules are also surely active, otherwise CSS/JS would not be compressed either.

    Furthermore, the HTML content headers that are sent to the browser are also proper and suggest that compression is "allowed". For the homepage, however, the entire size of the HTML response is roughly around 70KB. While that could be compressed sometimes there's a "threshold" set on server side for the minimum (and often maximum) file size that is actually compressed. That is, because while delivering compressed content should speed up the site, the compression process itself also adds some "overhead" and additionally, compressing very small files (though that applies mostly to files less than 1KB or even smaller) can actually make them bigger instead of smaller.

    Please note: the compression itself is a server-side thing/process. Hummingbird only adds rules to enable it but they may or may not work, depending on what is allowed on the server and compression settings/performance - these might also be restricted (e.g. to certain file types and/or file sizes) on a server by the host.

    I know that you have contacted your host already and they confirmed that the compression is allowed and all the pre-requisites are met there but I think you might want to ask them again about two things:

    1) "text/html" Mime type - if there are any restrictions on that on their end?
    2) if there's any "threshold" set on compression, like minimum/maximum size that falls under compression.

    However, before you do that, there are also two other things that might be relevant. First one is a possible interference from the theme or some other plugin. That could be checked by running a full conflict test, have you tried that already? If not, please give it a try by following this flowchart here:

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Second thing is: do you have any additional CDN implemented for site/your domain? I "tracerouted" the domain and it doesn't look like there is any external CDN but sometimes this check is not quite "trusty" and you'd better know whether you got it or not. If yes, try temporarily disabling it so the site would be accessible directly without CDN (note: WPMU DEV CDN in Hummingbird doesn't count here).

    Kind regards,
    Adam

  • Alfredo

    Hi Adam!

    MAny thanks for all your advice.
    I did a conflict check as you have explained and still having the problem when I deactivate all plugins and leave on only Hummingbird. Also changing the theme but still not doing HTML compression. So we discard theme or plugin conflict.
    I don´t have CDN
    So now I´m going to ask this 2 things to the hosting service.

    I´ll be back when their answer.

    MAny thanks!
    Alfredo

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.