Gzip isn't working properly

It's giving me this message.

Gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

I have tried disabling other plugins to see if that helps. Doesn't. I contacted my hosting provider who said that the deflate module is active.

  • Katya Tsihotska

    Hi Jocelyn

    Hope you're fine today!

    Did you try to manually activate it? If no, could you try?
    Go to the Hummingbird -> GZIP Compression page and choose the Manual tab:

    Then copy&paste the code to the .htaccess file at the root folder of your site (always back up this file before editing).

    If it doesn't help, please double check the following points (you'll probably need to contact your hosting provider):

    1. Check if there's a Varnish cache running on the server (or any other server-side caching solution) and make sure to purge/empty it

    2. Make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":
    zlib.output_compression = On

    In case it's set to "off" you will want to change it to "on" and restart Apache

    3. There's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    If anything mentioned doesn't help to resolve the issue and you are still having troubles with this you can send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me :slight_smile:

    Kind regards,
    Katya

  • Katya Tsihotska

    Hi Jocelyn

    Hope you're having a wonderful day!

    It shouldn't take much time to take effect. Actually, it should take effect immediately. However, some changes in server configurations require restarting of the Apache. So, could you ask your hosting provider to restart Apache? If it doesn't help and if you ensure that required MIME types are set to be handled by "mod_deflate" module, then please, send us your credentials as I've described in my previous reply and we'll further investigate the issue.

    KInd regards,
    Katya

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.