GZIP Not Able to Write

I've tried to enable compression with Hummingbird and I get an error message saying to contact support for help. I did update the HTACCESS file with the code that was generated, but it seems something else is wrong.

  • Kasia Swiderska
    • Support nomad

    Hello Jeff,

    Does error message say that:

    gzip is not working properly:
    - Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
    - Another plugin may be interfering with the configuration
    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

    or there is another issue with enabling gzip? If that's the error did you check with your hosting provider if deflate module is enabled? If they confirme have your run conflict test to exclude that another plugin is interfering with Hummingbird?
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it looks.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Jeff,

    Hope you are doing good today. :slight_smile:

    Thanks for confirming that it's already enabled, could you please try adding the following rule in your php.ini file, and then check whether it works fine:

    zlib.output_compression = On

    You'll have to create the file php.ini if it isn't present in the root directory. Root directory is where your /wp-admin, /wp-includes/, /wp-content folders reside.

    Please do let us know how that goes, if that still doesn't help, please do enable support access, so that we could have a better idea regarding this issue. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Jeff,

    Looking to the info got in the GZIP Compression "section" of Hummingbird, seems the compression is enabled to "text/html", so, it leaves me to think that can be some issue regarding to the MIME types: "text/javascript" and "text/css".

    Can you contact your hosting provider to confirm if the "mod_deflate" module supports those MIME types? Because there is a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css".

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Jeff,

    Hope you are doing good today. :slight_smile:

    Could you please send us you credentials so that we could have a better idea regarding this. You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    HI Jeff,

    Hope you are doing good today. :slight_smile:

    Thank you for sending in the credentials, I checked your website, and it's configuration. It seems like all the settings seems to look fine, I'm not able to notice any issues that could be causing this. I'm pinging the developer regarding this, asking to give a closer look, so that he would be able to provide a better idea regarding what could be missing here.

    Will get back to you once I get an update from the developer asap. Please do note that developers work round the clock with many critical issues, and hence have a slow response time. Either myself, or the developer will keep you posted asap.

    Best Regards,
    Nithin

  • Rupok
    • Support Ninja

    Hi Jeff,

    So sorry for the delay from our end and I do apologize for this. Our developer checked your site and he didn't find anything which could be causing this from your site. So he suggested you to check with your hosting company to make sure if some global config is disabling javascript and css gzip for your instance.

    I can see that you have contacted your host before, but can you please talk to them again and ask them if they have gzip MIME type configured for CSS and JS, then why these are not working for your site?

    Please let us know what they say about this. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.