Gzip Not Working for HTML, CSS and Java they do

I've enabled gzip compression with hummingbird. It's working for java and css. However, I get the error message in the picture . I checked with my hosting provider (bluehost) and double checked that gzip is enabled. I am running an Apache server. Any help on getting this fixed would be greatly appreciated.

  • Katya Tsihotska

    Hi Dave Lambrechts

    Hope you're having a great day!

    Let me know did you try to do it manually? If no, could you try and check if it works. To do this, you'd need to go to Hummingbird > Gzip Compression page, select Server Type -> Apache and choose Manual tab.

    Follow the instructions from the Manual tab.

    If it doesn't help, please double check the following points (you'll probably need to contact your hosting provider):

    1. Check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    2. Make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":
    zlib.output_compression = On

    In case it's set to "off" you will want to change it to "on" and restart Apache

    3. There's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    Let us know about results.

    Kind regards,
    Katya

  • Dave Lambrechts

    Katya,
    Your response time is amazing. Here's what I've done. I contacted my host (Bluehost).

    1. There is no varnish cache running on the server
    2. zlib output was set to "off". Had them turn that on and restart Apache. Verified it was on here http://igbailey.com/phpinfo.php. This didn't fix the problem.
    3. The support rep from Bluehost said the MIME types have something to do with the developer and I needed to check with them. I pasted your entire line #3 into the chat with them.

    I added the code manually to the .htaccess file. You're probably going to have a good laugh at what I'm going to say. I'm not sure wtf I'm actually doing here. It looks like I have 3 .htaccess files. First one is located in the root, second in the public_html folder and third in the wp-includes folder. I'm not sure how these interrelate or if I'm supposed to have 3 of them at all. It looks like the one that Hummingbird and Defender modify is the one located in the public_html folder. So, that's the one I added the manual code to. <commence laughing> Here's the thing, in that particular .htaccess file, there seem to be a series of red upside down question marks. From a quick Google search it looks like that indicates a problem. However, i ran the contents through at http://www.htaccesscheck.com/check.cgi just to see if I could fix the problem if it was simple. However, the syntax out okay on that site. I'm not sure if this matters, but this is a multisite install.

  • Katya Tsihotska

    Hi Dave Lambrechts

    Hope you're fine today!

    3. The support rep from Bluehost said the MIME types have something to do with the developer and I needed to check with them. I pasted your entire line #3 into the chat with them.

    The MIME types usually can be enabled/added through the cPanel or another hosting panel which allows this. As an example here is documentation for cPanel:
    https://documentation.cpanel.net/display/68Docs/MIME+Types

    It looks like this issue requires some further investigation, for this, we will need to have access to your site and server. Could you send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -WordPress login URL

    -cPanel username
    -cPanel password
    -cPanel login URL

    If you don't have cPanel, you can send us your FTP or SFTP credentials
    -FTP credentials (host/protocol/port/username/password)

    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me :slight_smile: Let us know here once you'll send the details. Please, DO NOT post any credentials here, as it's a public forum.

    Kind regards,
    Katya

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.