Gzip not working properly. Do advise which plugin is interfering with configuration

gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration

  • Adam Czajczyk

    Hello Nicole,

    I hope you're well today and thank you for your question!

    Can you please tell me:

    - where the site is hosted (what's the host name)?
    - is there any CDN (Content Delivery Network) enabled for that site?
    - does this happen only on staging site or on a live site as well?

    It would also be great if you could enable the support access for me so I could take a closer look at your setup. To do this, please make sure that the WPMU DEV Dashboard plugin is active on your site and then go to the "WPMU DEV -> Support" page and click on "Grant support access" button.

    Looking forward to your reply,
    Adam

  • Nicole

    Hi adam,

    I've replied you on a previous email.
    To add on here on the answers, I hope it helps
    - where the site is hosted (what's the host name)?
    Vodien
    - is there any CDN (Content Delivery Network) enabled for that site?
    Not at the moment
    - does this happen only on staging site or on a live site as well?
    I have not upload this plugin in the live site. Only the staging site itself.

    I have already grant access. Do update me alright! Thanks for your help!

  • Predrag Dubajic

    Hi Nicole,

    Have you checked with your host that "deflate" module is enabled on your installation as this is required for GZIP compression to work?

    Also, make sure that the .htaccess rules are added properly, you can do that by going to Hummingbird > GZIP Compression panel, on right side click "Want to do it manually?" link and then compare the code from there with the one in your .htaccess file that is located in your root WP folder and make sure all the code is there.

    If above suggestions don't make any difference there's one more thing that may be going on, some hosting providers have GZIP compression rules predefined on server and don't allow these changes to be made via .htaccess rules.
    So what you can do is check this with your host as well and if this is indeed the case with them ask them to either enable GZIP compression for your site or at least allow the changes to be made via .htaccess.

    Let us know how it goes :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.