Gzip showing enabled partially

Gzip compression was working fine in the website. Once the plugin was updated, it's only showing as enabled partially under Hummingbird > Gzip Compression page. text/html isn't getting enabled, rest are shown as enabled in the site. Please check the chat notes for more info.

  • Nahid
    • Tech Support

    Hey Adnan !
    Hope you are having a great day!

    I took a closer look into the issue you are encountering with Hummingbird's Gzip Compression in your site and everything looks good from the plugin and WordPress side of things. I also initiated a plugin/theme conflict test (as you had approved our request to do that in your Live Chat session) and verified that htaccess rules are properly placed in your .htaccess file.

    In this scenario, please get in touch with your host and:
    1. Request them to check why the server isn't following the htaccess rules and thus not compressing text/html content.
    2. Ask them if Apache is the main web-server powering your site or if there is Apache as the main web-server but "in front of it" there's an NGINX instance (reverse proxy).
    3. Request them to check if the compression for text/html content is disabled and if they would be able to enable it from the Apache configuration.

    Hope this helps. We'll be looking forward to hearing back from you.Thanks!

    Kind regards,
    Nahid

  • Dimitris
    • Support Star

    Hello Adnan

    There was actually a setting in cPanel that was messing with it and that is zlib.output_compression. I already changed that in "MultiPHP INI Editor" for the specific domain, like below:

    and after re-checking status in HummingBird, all is green again!

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.