gzip unable to work on Wordpress site using DIVI builder. Apache server.

Gzip compression is not working on a WP site, using DIVI plugin, and is hosted on HOSTGATOR Apache server? Is there anything I can do, or what exactly do I need to ask HOSTGATOR to do for it to work please?

  • James Morris

    Hello Jezz,

    I hope you are well today.

    It's possible that Gzip is not properly enabled on your server. If you have a cPanel account, please go to "Optimize Website" and turn on compression for all file types. If that is all set, can you please try adding the following lines to your .htaccess file?

    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilter DEFLATE .shtml
    </IfModule>

    Once you add this, please go into Hummingbird -> Gzip and click on Re-Check a couple times.

    If this does not resolve your issue for you, please enable Support Access so we can look into this issue further for you.

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris