H1 still white on mobile using spirit theme

Spirit theme on kre8ive.space/guruwisdom does not show H1 on mobile, it works fine on laptop....any suggestions? Cheers, Inger

  • Milan

    Hello Inger,

    I hope you are having a good day and thanks for asking us. :slight_smile:

    Dear inger, I am not able to identify and probalamatic H1 on my mobile devices, elements with H1 in it seems to rendering without any issue. This my be my eyes fault too. :wink: So would you please take snapshot of your issue and attach it here, it will help me to identify where is issue. Don't worry you issue is very easy to fix, so just include snapshot and page link where you are noticing this and I'll move forward here with solution. :slight_smile:

    Looking forward to hearing back.
    Best Regards,

  • Adam Czajczyk

    Hello Inger,

    I hope you're well today!

    I was able to replicate the issue using Firefox "responsive view" tool. This is because most likely color for H1 tag is still set to white for mobile or mobile and tablet view on your site.

    To fix it:

    - open the page (e.g. the one you linked to in your recent post) in browser
    - enable Upfront editor
    - switch Upfront's panel to "Theme Settings"
    - select "Main Heading (H1)" from "Type Element" in "Typgraphy" tab

    At this point, you'll notice that the color is not set to white; that's why on desktops H1 answers are visible.

    - click on "Responsive mode" on the left of "Save" button (color is still not white, as you can see)
    - from the top bar select "tablet"
    - color for "Main Heading (H1)" should now change to white; use color picker to select other color of your choice that will be visible on white background
    - then from the top bar select "mobile" and repeat the step above
    - finally, use "Save" button to save changes and exist "Responsive" and "Upfront"

    This should fix the issue.

    Let me know if it helped, please!
    Best regards,