Hacked because not Updated 4.7

Hello together,

I was wondering if it's enough to just update Wordpress an delete the post that was injected, when your wordpress was hacked - because thats what I read a lot in different forums. I wouldn't feel very safe in that case? The question came up in my mind when I heard that from several people who had been affected - Isn't there still the danger that some bad code was placed somewhere? Or maybe I am overprotective?

  • Lindeni Mahlalela

    Hello,

    Thank you for contacting support.

    It may not be enough to just update and delete infected page. I suggest you install "Defender" our security plugin which will run regular scans on the WordPress core, plugins and themes and give you a report from which you can tell if your website is safe or not.

    You can get defender here https://premium.wpmudev.org/project/wp-defender/

    Once Defender is active on your site, it will also tell you which core files or plugin files were infected, this is useful because sometimes a hacker can install malicious files in your website folder and those files can cause a big damage in your website in the future if not removed.

    So, keep your WordPress core, plugins and theme updated and then get a security plugin like Defender to scan your site for any malicious files and get recommendations on how to solve those problems if there are any.

    I hope this helps you secure your website. Please let me know if you need any help.

    Cheers,
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.