Having a problem a problem with CoursePressPro - installed the plugin - tried to update - error

Support problem is for CoursePressPro - it is an update / install issue and it does not show on my list to pick ---- This is the second time I tried to update.. first time - errors showed but I clicked past it too quick.. it disappeared from my installed plugin list - I deleted the plugins folder via ftp, reinstalled and it worked.

Today got update plugin message - tried to update same thing happened.

This time I wrote down the error messages
-------------------------------------------------------------
the update process is starting. This process may take a while on some hosts, so please be

patient.

Warning: fopen(/htdocs/dgplos/wp-

content/plugins/coursepress/coursepress.php): failed to open stream: No such file or directory in

/homepages/htdocs/dgplos/wp-includes/functions.php on line 4004

Warning: fread() expects parameter 1 to be resource, boolean given in

/htdocs/dgplos/wp-includes/functions.php on line 4007

Warning: fclose() expects parameter 1 to be resource, boolean given in

/htdocs/dgplos/wp-includes/functions.php on line 4010

Updating Plugin (1/1)
------------------------------------------------------
The system had a message that the plugin updated successfully but at the main plugin page this message showed.
"The plugin coursepress/coursepress.php has been deactivated due to an error: Plugin file does not exist."

It is gone from installed plugin list..

This is only plugin I am having this issue with.. others upgrade normally.

Any suggestions - questions..