Having difficulty determining settings for padding appts

I offer both 60 minute and 90 minute appointments.
I need 30 minutes padding time between appointments.
The scheduling calendar does not always give me the 30 minute padding despite the settings.

I have opened up Saturday up to test this using combinations of 60 & 90 minute appts in the same day.

I have enabled support access.