Having issues with multiple WPMU plugins

Hi I’ve been having issues with a few of your plugins – connection errors mainly so I logged out of WPMU dashboard now I can’t log back in.

Also, I noticed that my backups are not being uploaded to the cloud. Was unable to update any plugins as well.

  • Nithin
    • Support Wizard

    Hi Bec,

    We were having temporary issues with WPMU DEV API and hence causing all the anomalies noticed. The issue has been fixed now, could you please log into the WPMU DEV Dashboard plugin, so that we could check whether the backups are working fine, or not, and check any of the issues further if needed.

    Please do let us know how that goes. Sorry for any inconvenience due to this. Have a nice day ahead.

    Best Regards,

    Nithin

  • Bec
    • New Recruit

    Hi Nithin

    Thank you for the update. I can confirm that I am able to log into the Dev Dashboard plugin again and have since run the plugin updates.

    Managed Backups to the Hub are still giving an internal server error as soon as it tries to upload to the hub.

    When I log into the Hub it shows that the backup is running but this is what was happening before the recent API issue.

    It would run for a few hours and then show as uploaded however the errors within Dev Dashboard plugin remain and because it shows an error on upload, the next scheduled managed backup doesn’t run.

    It looks like Snapshots have been working to Dropbox with no issues so it appears to only be the managed backups to the Hub giving the error message.

    Bec

  • Ash
    • WordPress Hacker

    Hello Bec

    Glad to know you can login now.

    Managed Backups to the Hub are still giving an internal server error as soon as it tries to upload to the hub.

    This seems there is an error. We need to check that error.

    Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now, let it try to upload the backup again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,

    Ash

  • Nithin
    • Support Wizard

    Hi Bec,

    Thanks for sharing the Debug log, from the given logs the following seems to be causing the issue:

    PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 52428832 bytes) in /wp-content/plugins/snapshot/lib/Snapshot/Model/Transfer/Upload.php on line 51

    The above fatal error states the system is running out Memory Resources, and that would explain the internal server error encountered while running the backups.

    On further checking the memory_limit in the server-side seems to be set to 128M, which is low. I tried to create a php.ini file in the root directory to increase the memory, but unfortunately, it doesn’t increase the value.

    Most probably your server doesn’t allow to increase the resources via php.ini. Could you please get in touch with your hosting provider, and ask them to increase to at least the following values defined:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 800

    Once increased, please let us know how a new backup goes so that we could give a closer look if needed. Have a good day.

    Kind Regards,

    Nithin

  • Bec
    • New Recruit

    I have updated the php.ini file via cPanel to the above values except for post_max_size as it would only allow me to increase it to 128M.

    The backup has now successfully completed upload to the Hub and I will monitor it over the next week to make sure the next one runs with no issues before marking this ticket as resolved.

    Thanks for all the assistance!!

    Bec

  • Bec
    • New Recruit

    Hi

    I’d love to mark this as resolved but unfortunately I’ve run into new problems. The backups to the hub continue to work without an issue however the daily snapshots to Dropbox no longer run automatically and I have to log in and manually run them.

    I have tried resetting them but the problem remains.

    I’m also finding that SmartCrawl can’t run it’s SEO Checkup. This runs both automatically and manually triggered until 10%, freezes there for 10-30mins then skips to 100% before throwing an error that says ‘we weren’t able to get meaningful results’.

    Everything is up to date – could this be a hosting problem?

    Bec

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.