Having problems when I post from my mobile device.

I'm using the status update plugin in my sidebar. The plugin works great on my laptop, but it doesn't update when I post from my mobile device. Why?

  • Adam Czajczyk
    • Support Gorilla

    Hey Willie,

    I hope you're well today and thank you for your question!

    The "Status" plugin by design doesn't differentiate between posts being posted via desktop and via mobile browsers, so I suppose that's the result of some other related settings.

    Would you please give me a helping hand here?

    1. What's the type of mobile device in question (including OS and browser)?
    2. Have you tried with other mobile devices?
    3. Does the issue relate only to updates via Status or to "standard" WP posting as well?
    4. Are there any caching plugins active (e.g. W3 Total Cache)?

    Please advise.

    It would be also great if you could grant me a support access so I could take a closer look at your setup. To do this, please follow this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Cheers,
    Adam

  • Predrag Dubajic
    • Support

    Hi Willie,

    Apologies for the delay on this thread.

    Thanks for granting access, I have tested your site and status works fine for me on mobile device as well, tested on Nexus 5, see screenshot attached below.

    Can you please answer to questions Adam posted above so we can try finding out the cause of this.

    Best regards,
    Predrag

  • willie
    • Flash Drive

    I just tried it again, but for some reason it is still not posting on my mobile device. If the status plugin is in the sidebar. But to answer the your questions
    1. What's the type of mobile device in question (including OS and browser)?
    I'm using my Samsung S5 for a mobile device. Google chrome

    2. Have you tried with other mobile devices?
    Yes I'm tried my daughter's phone as well. She has a ZTE

    3. Does the issue relate only to updates via Status or to "standard" WP posting as well?
    Just only updates

    4. Are there any caching plugins active (e.g. W3 Total Cache)?
    I'm using WPEngine. They do not allow 3rd party caching plugins.

  • Adam Czajczyk
    • Support Gorilla

    Hello Willie,

    Thank you for your feedback. I asked this because caching plugins are often causing such problems and it's worth checking. I'm also aware of many cases where the issue turned out to be OS/browser specific.

    That said, I tried to access your site again but I wasn't able to. It seems that the support access has already expired (it's usually 72hr valid) so could you please re-grant it for me?

    Thanks,
    Adam

  • Predrag Dubajic
    • Support

    Hi Willie,

    I had another look at your site and noticed that the issue is with the theme you are using, it looks like the theme is calling two same sidebars on page, and that is causing the issue with the buttons since two ID's are on the same page.

    To see this open your site on your laptop, resize the window until sidebar disappears, open the sidebar by clicking on "hamburger" menu and then resize the window to fullscreen.
    You should see two sidebars as shown in attached screenshot.

    You should contact theme developers with this issue as they should be able to give you more precise answer on why the sidebar is working this way and it's being called twice.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.