having some major problem with plugins

hey

i am having some major probelms with facebook plugin

1. when i install the plugin and then open the site in internet explorer the site moves to the right side of the screen.

i cheked all other plugins and this is 100% the one that is doing the problem.

please note: this problem is happning only when surfing on explorer not on chrome or firefox.

the site link http://vtrack.co.il/themes/ofek1/

2. when cliking on activate like button - nothing is happening.

3. also i am having a problem with your main theme, when i try to install a plugin it shows the it is downloding then installing and it dose not show that it finised the job. same problem when trying to poset this support ticket.

please help.
thanx

eli

  • Patrick
    • Support Monkey

    Hi there @eli

    Welcome to the forums, glad to have you aboard!

    1. Yep, IE can be a pain. Likely, adding a DOCTYPE to the header of your child-theme will solve the IE display issue:
    http://stackoverflow.com/a/3868037

    2. Which button are you referring to? Do you mean the "Allow Facebook Like Button" setting in Ultimate Facebook (screenshot)?

    If so, there may be a conflict with Facebook scripts already running in another plugin or your theme. Please try basic troubleshooting protocol as illustrated in the diagram at the bottom of this page:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    3. Exactly which theme are you referring to here? It appears that you are using a child-theme of The7 theme on your site:
    http://themeforest.net/item/the7-responsive-multipurpose-wordpress-theme/5556590

    Are you perhaps referring to your WPMU DEV Dashboard plugin? If so, there again, there may be a conflict with something else active on your site. That would be another thing to check for while you're troubleshooting as above.

    Can you please provide a bit more information as asked above and let us know how the troubleshooting goes?

    Thanks!

  • eli
    • WPMU DEV Initiate

    thanx for your response.

    1. i have added this <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> to the chiled theme as you said, still no change.

    2. disableing all plugins didnt help, the plugin is still not showing the like buttons.

    3. yes, i was talking about the WPMU DEV Dashboard plugin, this problem is anoying but not a big one.

    4. when trying to grant extra premmisions i get this messege from facebook:

    "Application configuration does not allow the URL given.: URL address one or more of the addresses given are not permitted by the application configuration. They must adapt to the URL of the site or application page or domain to be a domain of one year of application domains."

    5. if i buy a plugin without a membership will i be able to get all plugins updates?

    thanx

    eli.

  • Ash
    • WordPress Hacker

    Hello @eli

    1. Which version of IE you are checking in?

    2. When you check the button, what do you mean by nothing works? Do you mean no like button is shown in your site?

    3. Would you please enable support access from WPMU DEV > Support so that I can check?

    4. This is because your app is not set up correctly. Would you please post a screenshot of you fb app where you have entered your site url?

    5. No, you won't get any update and even you won't be able to get any support.

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    3. I have just tested and it's working fine for me, screenshot attached. I have installed popup plugin, you can remove it.

    1. I have deactivated UFB plugin and still sees the site incorrectly in IE, so this is a theme issue. Would you please check by deactivate the UFB plugin again?

    2 & 4. Would you please create an correct app and check if the issue exists?

    Please let us know.

    Cheers
    Ash

  • Michael Bissett
    • Recruit

    Hey @eli,

    I think I've discovered the problem here. The <svg> tag (it has the id of "svg-source") that shows up inside the <body> tag seems to act up when Ultimate Facebook is enabled, since it has a inline CSS property of "margin-left: -100%".

    To remedy this, I had to install a CSS plugin on your site (the custom CSS section inside your theme wasn't overriding the CSS that was being applied via the theme itself), inserting the following code into it:

    #svg-source {
    margin-left: 0 !important;
    }

    And now, the page is properly aligned, even with Ultimate Facebook enabled. :slight_smile:

    Could you verify that it's working properly on your end as well?

    Please advise,
    Michael

  • Michael Bissett
    • Recruit

    You're welcome @eli, glad I could get that fixed for you. :slight_smile:

    As for your question, we do have a shortcode you can use for the like button, it's the [wdfb_like_button] shortcode.

    You can check out a list of shortcodes we have available by going to Facebook -> Shortcodes inside your site's Dashboard.

    Hope that helps!

    Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.