Having trouble upgrading to Membership 2

I'm trying to finally upgrade from Membership (version 3.5.3.3) to Membership2, now that I see 2Checkout gateway is supported by the new plugin.

However, the button to unlock the upgrade doesn't appear. Also, the plugin doesn't seem to register as installed for purposes of this support form (I couldn't select it in the drop down as an installed plugin, hence why I've been forced to select the Dashboard).

I've granted support access, so feel free to take a look yourself.

Please let me know what I need to do.

  • Michael Bissett

    Hey @Ben, Michael here!

    I do see what you mean here, and will report this to our developers.

    In the meantime though, as a workaround, here's what you can do to migrate over to Membership 2 Pro:

    #1: Log into your site via FTP, and rename the "membership" folder inside of:

    /wp-content/plugins/

    To something else, like "membership-old".

    #2: Then, inside of our Dashboard plugin, search for "Membership 2" (without quotes) inside of:

    WPMU DEV -> Plugins

    Install the plugin, and activate it.

    #3: Reload the page, and then click on the "Membership 2" menu item, that'll take you to a page where you can import your old Membership information.

    Hope this helps! :slight_smile:

    Kind Regards,
    Michael

    • Ben

      Thanks, but when I try that the import doesn't work properly. If I complete the import data task, it eventually loads no members or subscription plans.

      Frankly this is getting to be extremely frustrating as I faced the same errors last summer before deciding I had to wait until the 2Checkout gateway was supported in the new plugin anyway. 6 months later, I saw the gateway is now supported so I can keep my existing subscribers without having to have them sign up again so I decided to go ahead and try to upgrade. Only to face the same importing issues.

      I hope this is sorted out soon because right now I'm feeling like my wpmu subscription is a waste...

  • Michael Bissett

    Then let's try a couple things @Ben. :slight_smile:

    #1: Log into your site via FTP, and insert these two defines into your site's wp-config.php:

    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    You can also try inserting this in there as well:

    @ini_set( 'max_execution_time', 300 );

    Make sure all of these are inserted above this line:

    /* That's all, stop editing! Happy blogging. */

    #2: As you've downgraded to Membership Premium, try doing the upgrade to Membership 2 Pro, and this time, set the "Batch size for import" to "Small (10 items)", and try doing the import.

    If that doesn't work, then you'll want to head over to:

    Membership 2 -> Settings -> Import Tool

    Choose the "Membership (WPMU DEV)" option there, and click on "Preview Import". Set the batch size to "Small (10 items)" again, and try doing the import.

    If that doesn't work, then we'll dig deeper, and work on annihilating that frustration. We'll need to have the following sent in via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.