Having trouble with a wordpress query

I am attempting to run a query to get this to work, however for some reason i am not getting any results returned.

add_action( 'blog_templates-copy-after_copying', 'nbt_hooks_copy_contact_form_7_forms', 10, 2 );
function nbt_hooks_copy_contact_form_7_forms( $template, $destination_blog_id ) {
	global $wpdb;

	if ( ! function_exists( 'is_plugin_active' ) )
		include_once( ABSPATH . 'wp-admin/includes/plugin.php' );

	switch_to_blog( $destination_blog_id );
	if ( ! is_plugin_active( 'contact-form-7/wp-contact-form-7.php' ) ) {
		restore_current_blog();
		return;
	}
	restore_current_blog();

	// Now, to change the recipient email
	switch_to_blog( $destination_blog_id );
	// We get all the posts IDs that has _mail post meta (that belongs to a Contact Form)

        //THIS IS WHERE NO RESULTS ARE BEING RETURNED
        //WHEN THERE SHOULD BE
	$results = $wpdb->get_col( "SELECT post_id FROM $wpdb->postmeta WHERE meta_key = '_mail'" );

Exploring the database via phpmyadmin I can clearly see that there is data here.

I have also tried the results query with:

$results = $wpdb->get_col( "SELECT post_id FROM postmeta WHERE meta_key = '_mail'" );

And still get nothing.

Tried running other basic queries, nothing.

Anybody have any ideas?

when i echo $destination_blog_id it shows the correct blog i am looking for data from and when I run get_current_blog_id() it shows the proper blog id.

This query is part of a plugin I am attempting to get working located in the mu-plugins directory, but this is where its getting stuck. I am using the wpmu multi-db plugin on a multi-site.

Would love some incite, thanks!