Having trouble with multi-domains plugin

I have a site at dem.co it is a multi site install that works fine for adding sites under that.
I have installed the multi-domains plugin and added some domains there. I have setup the dns to all point to a dedicated IP All the domains ping there as far as I know.

I can add sites at will on the dem.co domain (which is the actual wordpress install) when I add a site under one of the MS domains, it jumps straight to home on the dem.co site.

DNS background, I was able to install the domain mapping plugin and map domains to sites successfully, using the proper dns techniques. I have removed all mapping functions at Ivan's request so we can try to resolve the issue.

  • Mason


    First off, welcome to WPMU DEV!

    I can add sites at will on the dem.co domain (which is the actual wordpress install) when I add a site under one of the MS domains, it jumps straight to home on the dem.co site.

    This happens without any domain mapping or multi-domain installed?

    Are you running a sub-domain or sub-directory install?

    If other sites are redirecting to your main site on the front end (even if being displayed in the admin) this is probably a sign of either an issue in your htaccess file or that mod_rewrite isn't enabled correctly in apache.

    If it's the first one, you can post your .htaccess rules here and we'll have a look. The second issue would be something your hosting provider would need to look into.

    Can we get a link to a couple sub-sites as well? Probably can help ya get this sorted quickly that way.


  • cjon316

    with multi domains installed i can add sites at will to the primary domain dem.co
    none of the associated domains will allow addition of a site under them, but instead jump straight to the dem.co website.

    it is a sub directory install.

    the sub site links are as follows dem.co/agri

    there are a few others.

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L] RewriteRule . index.php [L]

    # END WordPress

  • cjon316

    posting wp-config.php for the benefit of those who can help: By the way, YES I did remove the essential details from the database variables at Barry's request.

    * The base configurations of the WordPress.
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    * @package WordPress

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    /** MySQL database username */

    /** MySQL database password */

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    * Authentication Unique Keys and Salts.
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    * @since 2.6.0
    define('AUTH_KEY', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('SECURE_AUTH_KEY', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('LOGGED_IN_KEY', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('NONCE_KEY', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('AUTH_SALT', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('SECURE_AUTH_SALT', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('LOGGED_IN_SALT', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');
    define('NONCE_SALT', '3NXTtK2WWAtBlhPP5d1mvHiYEDg2ZhxoPjsx9qEHHwUBcF7ehJZVzzWWABpoocTI');


    * WordPress Database Table prefix.
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    $table_prefix = 'wp_';

    * WordPress Localized Language, defaults to English.
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    define ('WPLANG', '');

    * For developers: WordPress debugging mode.
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'dem.co' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    define( 'SUNRISE', 'on' );

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • cjon316

    Perhaps my issue is a misunderstanding. I thought the multi domains plugin would allow you to add additional domains to the "network" or the multi site configuration. and then add a site under one of the new domains.

    My main site is dem.co
    I can add a site underneath it like rv, tc, etc.
    then it makes a place called dem.co/rv which is a fully functional site on its own.

    I had added a domain to the multi domains plugin called maurermfg.info
    I went to add a site under that domain using the system, but rather than adding a site to the network, it just jumped out to dem.co

    I have explained this as my issue, but never got anywhere. I have had the dns examined quite thoroughly during chats, and I though earlier in this forum as well. I was assured that the dns was looking fine.

    I do not have the plugin active at this time because I cannot get it to work. But by work, I mean, I cannot add a site to a different domain.

    I am able to add sites at will to the main domain (the only domain currently) and use the mapping plugin to route a domain to that site.

    As an example the benefits site is routed to a domain via the mapping plugin. benefituniversity.com works as it should. demcoprinting.com routes to the dem.com/printing site.

    So in summary, the plugin does not allow me to add a site under a different domain. Is that what the plugin is supposed to do in the first place?

  • Aaron

    I went to add a site under that domain using the system, but rather than adding a site to the network, it just jumped out to dem.co

    Can you describe how you did this?

    How it's supposed to work is when signing up at dem.co/wp-singup.php the user can choose which which domain to use as a root via the dropdown, such as maurermfg.info/thiersite/.

    If you try to visit maurermfg.info or maurermfg.info/wp-signup.php directly it should redirect to dem.co.

  • cjon316

    No. This is not sorted. As I stated, I had to remove the plugin because it would not work.
    I had the proper sunrise file installed.
    I now am using exclusively the domain mapping plugin.
    Might I suggest for ease of troubleshooting that you have a sunrise php file that is uniquely named for each scenario? like multidomainsunrise.php and domainmappingsunrise.php and multidomainandmappingsunrise.php

    That would eliminate signifcant questions and time taken by the troubleshooting process.

    I still really want to get this to work, but I cannot spend the troubleshooting time reboiling the answers to the same questions fielded by several different representatives and end up getting nowhere.

    What is it that I am missing? I cannot run the plugin in conjunction with the mapping plugin?
    Mapping is working perfectly right now, so I am not going to open this can of worms again until I have the hands on support promised with membership.



  • cjon316

    I do understand what it is, I just have never seen such a thing before anywhere else. I simply don't agree with the programming logic to have 3 unique scripts using one filename.

    Perhaps sunrise should be coded to be universal, and have sunrise figure out what plugins are installed. Or have a php switch in the top of the sunrise file that says 1 2 or 3. for the specific configuration.

    My larger point is, I spent more time discussing which version of sunrise.php I had installed, even when the only plugin I was using was the multi-domain plugin.

    An even larger point is I believe I am not the only customer who has fielded the question about which version of sunrise.php we are using.

    Can't it be defined if sunrise in wp-config if multidomain if mapping if both?

    This does not have to be done with a single php file with the identical name.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.