HB is having some issues on the site

The site seems too slow when HB is active. Now, I have kept it deactivated.

  • Kris
    • Support

    Hi Børge

    Hope you are doing good today.

    Hummingbird is deactived now but I cannot reach you site at all even using VPN from many locations.

    I get error all the time:

    Resource Limit Is Reached
    The website is temporarily unable to service your request
    as it exceeded resource limit. Please try again later.

    Also this tool https://www.uptrends.com/tools/uptime confirm that site is not reachable from any location.

    Above error mean some other process on site could possibly make this error or server resources could be low (CPU/disk space) or some custom plugin with script which could make many cron jobs.

    As I was not able to log in to site could you also send your cPanel details so I could take closer look on this?

    Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is “I have a different question” and:

    – Mark to my attention: ATTN: Kris Tomczyk

    – cPanel credentials (login url / username / password / port)

    – Link back to this thread

    Please don’t share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it.

    Please confirm here in thread that you have sent that message.

    Kind Regards,

    Kris

  • Kris
    • Support

    Hi Børge

    Hello. I disabled the snapshot pro plugin from you, and now it looks like the site is running much better. Could this plugin cause the resource problem?

    If server resources are low this could cause some issue with server I/O when backup cron is running.

    However Snapshot is disabled now and I try from two different browsers and from other agent location and in both cases we see this error on your site:

    Also non of this tools:

    https://www.uptrends.com/tools/uptime

    https://gtmetrix.com/

    https://developers.google.com/speed/pagespeed/insights/

    can ping or reach your site. Can you ask hosting provider to review server logs and is there is something suspicious which could make those downtime for site?

    Kind Regards,

    Kris

  • Børge
    • Flash Drive

    Hi! I have forwarded your questions to my host – but fo me the site looks online.

    My test at gtmetric.com – site online:

    https://i.imgur.com/brKSjOd.png

    My test at uptrends.com :

    https://i.imgur.com/G1xzcq0.png

    My test at dev google – site online:

    https://i.imgur.com/jKtC7ej.png

    So 2 of 3 test indicates the page is online. I can reach it from mobile and different browsers. I had the “resources” messages first but cleared cookies and now it loads.

  • Nithin
    • Support Wizard

    Hi Børge,

    Sorry to hear about the ongoing issue. Could notice what you have pointed in the screenshots. However, the GtMetrix, Google Page Speed, Uptreds are correlated to the website load too.

    At the moment I could notice the Hummingbird Pro plugin is deactivated, and similar issues occur, and the dashboard and the website are slow when accessed.

    I checked in Pingdom regarding whether it's detecting any specific plugin files causing such load in your system, but could only notice the following:

    Where the test is pointing that the server is taking around 6.8 seconds to establish an initial connection, I couldn't notice any other files in the results which would be causing this.

    https://tools.pingdom.com/#5b24eab407000000

    What Hummingbird does apply application-level fixes. If the server, in general, is loading slow no amount of application-level fixes would help improve this. Trying to run Hummingbird will only increase the load to the server at the moment.

    Did you bring this into your hosting provider's attention regarding? Please do let us know what your host has to say regarding these so we could check further once how the site behaves once HB is active too.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Børge,

    They have told me that this is because the site uses too much resources.

    Easiest would be to increase the server resources so the resources would be allocated without much load. This is something you’ll have to get in touch with your hosting provider to increase the server resources.

    Other than I’m afraid, that you’ll have to delete plugins which you think aren’t used much in your website to decrease the load on the system. However, this won’t bring much significance if the issue is more within the server-side, but can make some difference.

    You might find the following link helpful for more steps you could check regarding this:

    https://onlinemediamasters.com/reduce-server-response-time-wordpress/

    Kind Regards,

    Nithin

  • Børge
    • Flash Drive

    Hello. I have updated all plugins and removed all plugins that i do not need.

    The site is now moved over to a litghtspeed server, I will see if this makes any difference.

    Host told me some other things also should be fixed, see attached photo.

  • Ash
    • WordPress Hacker

    Hello Børge

    The first two major points can be fixed using HummingBird Pro and Smush Pro. For defer parsing, in HB asset optimization section, in advanced mode there is an option to defer scripts. You can use that. But note that, this is tricky that sometimes it can break your site. So, I recommend to change 5 files at a time, check the front end and if everything is okay, do that for next five files.

    For scaled image, if you use CDN within Smush Pro, there is an option “Automatic Resizing”. That will serve the image based on the container.

    I hope it helps! Please feel free to ask if you have any more questions regarding this.

    Cheers,

    Ash

  • Nithin
    • Support Wizard

    Hi Børge,

    Can you help me with this? I am unable to enable lithspeed plugin after using the

    I don’t see Hummingbird plugin installed in your dashboard at the moment. Since you are looking to make use of Litespeed cache, most probably the notice is due to the advanced-cache.php file from the following directory path added by the Hummingbird plugin when Page Caching was enabled:

    /wp-content/advanced-cache.php

    I have removed the mentioned file, which created a new advanced-cache.php file related to LiteSpeed Cache and now there aren’t any such notices as shared in your screenshot.

    Please do check, and let us know if you have any further query.

    Kind Regards,

    Nithin

  • Børge
    • Flash Drive

    For some reason some of my property data on the sub-site does not work now. Can this be a caching problem? This has worked fine before.

    Please take a look at this page:

    https://somna.digitalhavn.no/wp-admin/post.php?post=3850&action=edit

    Plase note that you have to login to access that page. When logged in, try to view the page. It comes out blank. Also you can access the pages from here, they also does not show the data they should:

    https://somna.digitalhavn.no/kaier/

  • Ash
    • WordPress Hacker

    Hello Børge

    It doesn’t look like a cache issue, rather it seems a plugin or theme issue.

    Would you please take a backup of your site first, install a default theme like 2019 or 2018 and then check if the data shows in that property page?

    Please let us know how it goes.

    Cheers,

    Ash

  • Nithin
    • Support Wizard

    Hi Børge,

    Can you please help me to get this working again with the theme that is now active?

    I checked further regarding this, the issue in the /kaier page:

    https://somna.digitalhavn.no/kaier/

    It should be fixed now. I copied the template file property-for-grid.php from the parent theme to the child theme under:

    /inspiry-real-places-child/partials/property/templates/

    And the page now loads fine. However, for the property single pages ie /kaier/berg/, kaier/viksjoen/ etc are still blank. It seems to be the same even when I switch to the Parent theme.

    Since it’s a 3rd party theme not sure whether it’s due to any missing configuration, or something else specific to the theme side. Are the Kaier properties part of a theme or a plugin? If it’s part of the theme would recommend checking with the theme support regarding the empty /kaier/berg/ pages.

    Please do check, and advise if I had missed out anything. Have a good day.

    Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Børge,

    Sorry about that, I have reverted the changes, and now it should be listed as boxes as you have mentioned. Since you did mention it’s blank, I assumed it was related to missing images as shared in your above page link:

    https://somna.digitalhavn.no/kaier/

    Seems like you meant about the single custom post type pages being blank, right?

    https://somna.digitalhavn.no/kaier/berg/

    These pages don’t seem to work even in parent theme out of the box too. I downloaded the themes into my test server, and it works out of the box in general with Custom Post Type.

    Seems like the issue is specific to Property Custom Post Type, could I know how the mentioned post type is added? Is it via plugin or custom code?

    Could you also enable support access to your website so that I could check the network side settings, the current admin login shared doesn’t give access to the WP network dashboard, and only to the main site.

    Please do check, and advise if I’m missing anything specifically with what you have raised too.

    Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Børge,

    I went ahead and downloaded the Inspiry Real Estate plugin, and the single properties page do work out of the box without any issue when tested in my test server.

    Maybe an existing plugin is causing a conflict with your premium theme, as I could notice the issue with /berg page to load blank is due to a 404 error getting generated.

    https://somna.digitalhavn.no/kaier/berg/

    Could you please deactivate all the plugins except Inspiry Real Estate plugin, and then refresh the Permalinks, under Settings > Permalinks in the dashboard side by re-saving the settings again, and then check whether /berg page loads fine?

    Wasn’t sure whether you would be comfortable with us making the above test, so haven’t done it yet. Please do let us know how that goes so that it would give a better idea on where the issue is located.

    Also, the premium theme and the custom child theme has too many similar page template used which makes it difficult to find out which exact template is used. If you are aware of the page templates which are used in the theme side for the /berg page, please do point that out in the next reply too.

    Regards,

    Nithin

  • Børge
    • Flash Drive

    The somna.digitalhavn.no is not public, so you can do any changes to it, no problem! Also I have a backup from before you started the work.

    I am not sure what page template that has been used for these kind of pages.

    If you disable plugins, can you please make sure you activate only the plugins that are activated today. There are some other plugins now that are already deactivated.

  • Nithin
    • Support Wizard

    Hi Børge,

    Thanks for getting back regarding this. It seems like Blog Designer Pro is what's causing all these anomalies. Once I disabled the mentioned plugin in your website the Properties doesn't display even in the default Twenty Nineteen theme ie on this page:

    https://somna.digitalhavn.no/kaier/berg/

    I can confirm the Properties /berg worked fine out of the box in my test server with the child theme, and also with default WP theme out of the box in my system.

    I went ahead and installed Blog Designer Pro in my test server, and once done, I disabled the Blog Designer Pro plugin, and then the properties page isn't loading in my test site too ie for both Default theme, and also with Inspiry child theme.

    It was throwing "1" as an error instead of showing content in Twenty Nineteen theme, for Inspiry theme it was loading a blank page as seen in your website.

    Once I enabled the Blog Designer Pro Plugin the content loaded fine in Twenty Nineteen theme, but it wasn't the same case with Inspiry theme and was loading blank similar to the issue in your website.

    However, the properties page was supposed to be working fine irrespective of the Blog Designer plugin, but once the plugin is configured the content only shows up once only when it's active in the 2019 theme, and now a blank page in Inspiry theme.

    This is the same that's causing the issue with your website side too, and most probably one of the plugin settings isn't configured for the Property Custom Post Type or an existing configuration is overriding in the Blog Designer Pro

    I checked the plugin settings, but I'm not able to find anything helpful in general. I checked with our SLS(Second Level Support) regarding this, and since it involves 3rd party plugin, and themes what they could notice, or suggest is limited in this.

    I'm afraid, we could only recommend you to bring this into your plugin developers attention, or theme support in the case the plugin is bundled with the theme, and see whether they could guide you further as the issue is same with the parent theme, and not with any custom changes specific to child theme.

    http://support.solwininfotech.com/

    https://support.inspirythemes.com/

    Since there are a lot of changes, and they don't specifically point to the Inspiry theme, in general, I'm afraid what we could check regarding this is limited.

    Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.