Help! Fatal Error after update of Membership

I have had so many problems with the Membership plug in I was afraid to upgrade with the new version.

But, I went ahead and did it and now I have a fatal error and cannot access the site.

Fatal error: Cannot redeclare class twocheckout in /home/sisterh0/public_html/wp-content/plugins/membership/membershipincludes/gateways/gateway.twocheckout.php on line 9

Please help as this is a large membership site and my members will be e-mailing me.

Thanks,

JoAnn

  • Mason
    • DEV MAN’s Sidekick

    Hiya JoAnn,

    Quickest way to handle this would be to completely delete the membership files and then immediately upload a fresh copy. Sounds like something didn’t copy correctly during the upgrade. No worries as all your data is safe in the database.

    Please let us know if this fixes it for you.

    Thanks!

  • JoAnn
    • The Incredible Code Injector

    This has turned into a giant mess. When I reinstalled the old version of membership now my entire (very personal) site is wide open and I can’t seem to find a way to change the levels. They are all as they were before.

    I deleted the old membership files and installed the new membership plugin.

    Still same thing. Site is wide open. I deactivated BuddyPress to hide all the forums and oddly enough, the buddypress menu at the bottom is still visible and still accesses all the forums.

    I’m tearing my hair out here.

  • JoAnn
    • The Incredible Code Injector

    Okay, the site seems secure again. It was just a few settings, but I panicked due to the sensitive nature of the forum postings in this women’s support group.

    Now we will wait and see if the 2Checkout payments update. That was the issue before. I had to make all of the changes by hand. New members were added but their payments and expiration dates did not update and cancellations had to be manually removed.

    If that glitch has been fixed I will have a week long celebration!

    Thanks Mason for all your hard work.

    JoAnn

  • JoAnn
    • The Incredible Code Injector

    Barry, I can’t figure that BuddyPress thing out. I deactivated BuddyPress completely, yet I could still access the forums and groups.

    I had changed the main menu and deleted all the BuddyPress links thinking that would help, but the bottom BuddyPress menu was still visible and still active. Also, even though BuddyPress was deactivated I still had access to the BuddyPress settings and options on my dashboard.

    I refreshed my pages and even tried a new browser and they were still accessible.

    Doesn’t make sense. But I reactivated BuddyPress after I got my levels and options set correctly and it seems to be working just fine.

  • Barry
    • DEV MAN’s Mascot

    Ok, if it’s working for now then that’s good, but will definitely be worth keeping an eye on that, as that doesn’t sound healthy :disappointed: Any issues, shout and we’ll see if we can get on to your site and work out what’s happening.

  • Mason
    • DEV MAN’s Sidekick

    Thanks, sincerely, to Barry for pitching in here.

    JoAnn, did you open the new thread? Are we able to mark this one resolved? Want to make 100% sure before doing so.

    Thanks again and apologies for what I’m sure has been a stressful day :disappointed:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.