help fixing the error on the registration page?

Hi, Could i please have some help with fixing the error thats currently displayed on the registration page? screenshot - http://take.ms/fzlix

Domain - http://tinyurl.com/pbj74ov
Support Access is open until 1st June

Please dont post any brand related information/ screenshots or domain links as i have had issues with google caching this information and linking it to their google searches of my site ... very bad for brand... please use temporary image upload / tiny url / pastebin etc to mask this information.

Thanks

Tom

  • Luís

    Hi Tom ,

    Hope you're doing well today!

    1) You have the debug flag enabled in the wp-config.php? If yes, please disable, changing it to:

    define( 'WP_DEBUG', false );

    Sometimes it can be simple warnings that can not interfere with the website functioning.

    2) If the debug flag was already disabled, try a plugin conflict test, as described in the flowchart of the below page, to see if any plugin is conflicting:

    https://premium.wpmudev.org/manuals/getting-support/

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • Tom

    Hi Luis,
    Just went through and checked the wp-config was already disabled. also i went through an de-activated all the plugins one by one and seems like non of them were causing the issue. only time i didn't see the error is when i disabled woocommerece itself but them obviously all i could see was the woo commerce short code as opposed to the form itself.
    Here is the pastebin of the file where the error is stated - http://pastebin.com/6QK7JhaV
    on the line 525
    the code is as follows:

    call_user_func_array($the_['function'], array_slice($args, 0, (int) $the_['accepted_args']));

    as i dont really understand what any of it means i was hoping someone here might have a better idea about this and could help me both understand what the issue is and hopefully how to resolve it ?

    Support Access is open

    Please dont post any brand related information/ screenshots or domain links as i have had issues with google caching this information and linking it to their google searches of my site ... very bad for brand... please use temporary image upload / tiny url / pastebin etc to mask this information.

    Thanks

    Tom

  • Tom

    Following this i tried searching for similar issues and found this https://wordpress.org/support/topic/error-code-49
    towards the end of the page someone mentioned

    Jeremy Binns
    Member
    Posted 5 months ago #

    I eventually found a solution by replacing my child theme's functions.php with a fresh copy. The only thing that was in there was google tracking code, and I hadn't updated that for months, so I am unsure why it was suddenly causing a problem, but maybe this will help someone else.

    Madmunch
    Member
    Posted 5 months ago #

    I had the same problem as Jeremy described, same warning, and I did replace the fonctions.php in my childtheme, as he suggested. I seems to work for me too.. Ye!
    Thank you for sharing your solution.

    i guess i will try this too, the issue i have is that i have some custom code in the child theme's function.php file so unsure what needs to go/stay
    Here is my current child theme php file, - http://pastebin.com/brbAJ4mT

    if someone who understands this more than me could take a look i would really appreciate it.

    Thanks
    Tom

  • Luís

    Hi Tom ,

    Hope you're doing well today!

    You have a "remove_action" followed by an "add_action". Simply removing the call to this function may solve the issue. So, can you try remove the following "add_action" line in your functions.php:

    add_action( 'register_form', 'cptch_register_form', 20 );

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.