Help! I just installed and tried Cloner and it's locked up my WP Installation!

Help... I installed Cloner on my multisite network about 1hr ago... then tried to clone a simple site on my network. The status screen updated and the first copy operation passed, then the remaining Cloner operation updates said they failed. one after another. I tried to go to my site and they're all unresponsive, eventually I get a Database error in Chrome "Error establishing a database connection". I can't connect to my Cpanel, to my WP Admin pages, everything is down!

404 805 1174
HELP.

  • Tyler Postle

    Hey Robert,

    Thank you for the explanation here!

    Do you have FTP access? Can you go in and re-name or delete the plugins/cloner folder? This will deactivate the plugin.

    You say your cPanel is down too? It sounds like this could be a server side issue. Contacting your web host while we do what we can on our end will be a good idea too :slight_smile:

    Look forward to your reply here!

    If you're not comfortable going into your files via FTP then send in your credentials to me through our private contact form:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to your reply!

    Cheers,
    Tyler

  • Robert

    Tyler,

    The site just came back (after a LONG TIME) where nothing was responding on it's own. This is on our own VM at our data center, it has tons of CPU and disk resources.

    That said, I can now get back in... to both cpanel and the wp-admin sites and rekko.com and parkerati.com (are back up).

    rekko.com/parkerati-staging doesn't seem to come up, but rather the setup screen comes up. Now when I go, instead of the errors, I"m at this:
    http://cl.ly/image/12433o0Z0504

    As you can see CPU usage is up:
    http://cl.ly/1k2i0y0F2p2a

    What do I do? At least now there are no failures so far and the site is responsive. How well tested is this plugin? I didn't change the default settings (copying all checkboxes).

    What do I do? I'm afraid to even delete the cloned site as it's in progress. Plus I actually do need to have a cloned site if possible- - the whole reason for downloading the plugin.

  • Tyler Postle

    Hey Robert,

    Thanks for further explanation the situation there :slight_smile:

    It can sometimes take a little bit to copy all the data over to the new site. I'm thinking this is the case here, as your screenshots indicate it's copying correctly. Is it still copying now or has it finished?

    All our plugins are tested thoroughly before we release.

    Only in the forums will we post a beta version of a plugin and even then we make sure to clearly label it as such :slight_smile:

    Cheers,
    Tyler

  • Tyler Postle

    Hey Robert,

    I will do some more testing on my own install to see if I'm able to reproduce the error, if you get it again then definitely post in here so I can pass it on to the developers :slight_smile:

    Of course, we can't test it with all plugins because so many are out there; however, it should work and copy all your custom CSS over successfully. If you do run into any further issues, just let us know.

    Look forward to your hearing back.

    Cheers,
    Tyler

  • Robert

    Hi Max,

    I think Visual Composer is the biggest visual WP editor. I think it actually handled things well. The biggest issue is that you can have custom CSS on a per page basis (works unbelievably well) and Cloner worked fine. There are other issues where only *some* of the settings and components were copied. Specifically on parkerati.com there are a series of six columns, each with a query to return a category of posts. Curiously, it cloned three of them correctly and three columns either didn't have the category correct or it was missing completely. Weird that it worked for half of them.

    However, as you can tell from the ticket, the first time I ran it, it took down my VM and made all sites on our Wordpress Multisite install unresponsive for an hour. I could only ping the machine, nothing worked, not even our CPanel! Then it came back. It isn't a resource issue as I was able to go into our Xen Center and monitor things from there, but the Database connection error was real.

    There is still another issue where some custom JS code isn't working to make each row full height. Not sure why yet and what it didn't clone right.

    If you want, I can make a video to show you what is working and isn't as that would be much more helpful vs a long email trying to describe the same. My subscription is expiring soon, so let me know before it runs out. :slight_smile:

  • wp.network

    Hey @Robert

    Just want to make sure you know that I am not WPMUDev staff.

    Obviously, your description with help staff diagnose the issue though, and it was certainly informative for me. Thanks for sharing your experience. Imho, making the video might not be a bad idea for clarity's sake, if you've nothing better to do than avoid typing :slight_smile: That way you can have a video link ready for staff when they next check in.. might shave several hours off the communication cycle.

    @Tyler Postle or another WPMUDev Staff member will get it sorted soon enough though.

    Cheers,
    Max

  • Tyler Postle

    Hey Robert,

    Thanks for the explanation there, if you could still make a video to further explain that would be awesome, and a huge help for the developers :slight_smile: I'll see if I can get my hands on a copy of Virtual Composer from one of the other staff here and test this out in my own environment too.

    That's good to know that it clones all the separate CSS sheets too, thanks for mentioning that - I'm sure the question will get asked again down the road.

    Look forward to hearing back Robert!

    Cheers,
    Tyler

    PS. Thanks for chiming in Max, I actually have Dynamik myself - it's very cool - I'll see if I can test that out with Cloner in my spare time here and let you know how it goes :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.