Help, I keep getting this message

Your server had a problem connecting to WPMU DEV. Please try again.
If this problem continues, please contact your host and ask:
"Is php on my server properly configured to be able to contact https://premium.wpmudev.org/wdp-un.php with a GET HTTP request via fsockopen or CURL?"

I contacted my host provider and they said the link posted doesn't work, but the problem should be solved, and they were right, it did for a second but I was logged into the dashboard and then I got another message that says "You do not have sufficient permissions to access this page." I did let my host know of this issue as well, I tried to go straight to my wordpress dashboard and it allowed me back in but I was signed out of the wpmudev dashboard. I tried logging in again and I keep on getting; "Is php on my server properly configured to be able to contact https://premium.wpmudev.org/wdp-un.php with a GET HTTP request via fsockopen or CURL?"
Again and again.
I also see
Warning: uasort() expects parameter 1 to be array, null given in /home/hypelicc/public_html/wp-content/plugins/wpmudev-updates/update-notifications.php on line 1762

I've tired it both on multisite and on just regular wordpress install and I keep getting the same issue.
I have uninstalled and reinstalled WP plugin several times as well, hoping that would solve my issue and still, no change.
I am very new with this sort of stuff so please help me as soon as possible.
Thank you.