Help in Debugging: Internal Redirects

Hi,

I am getting following error across all sites in my Multisite Network:

[Fri Jan 13 05:19:23.385771 2017] [core:error] [pid 18106:tid 140334373734144] [client 127.0.0.1:42333] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: https://directory.edugorilla.com/coaching/dilsukhnagar-institute-dilsukh-nagar-hyderabad/

I agree this error is well discussed in support forums. I also tried modifying Apache Config, .htaccess and wp-config.php to fix it but nothing happened.

I also tried plugin conflict test but unable to understand root cause.

It shows Loglevel Debug. Is it possible to debug the error leveraging that functionality. When I tried doing it myself, I was confused with quadron amount of generated log.

Currently because of this error, I have to use 4-5 times bigger hosting package then required.

Thanks

  • Dimitris
    • Support Star

    Hey there Rohit,

    hope you’re doing good and thanks for reaching us! :slight_smile:

    I just scanned your website via our checkup tool here

    https://premium.wpmudev.org/wp-checkup/

    and seems rather good. I also tried to navigate to the page in description and it was loaded pretty quick in my end.

    Is this multisite installation inside a subfolder in your server? Or is it in the documentRoot path (most of the times it’s /public_html folder)?

    Please advise!

    Could you please download your .htaccess file, rename it to htaccess.txt and attach it here in your next reply?

    Finally, could you please grant us support access to your website via WPMUDEV Dashboard plugin? Here’s our (new) doc page about it https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Warm regards,

    Dimitris

  • Rohit
    • Site Builder, Child of Zeus

    Hi Dmitris,

    Thanks for running the check.

    WordPress is installed at /opt/bitnami/apps/wordpress/htdocs/.

    Also, I can see abnormal CPU utilization in last 6 hours:. It looks like a cron job with a timeout to me but I am not sure which plugin is running it.

    I have only 5000 sessions (evenly splitted) in a month but out of blue from last 48 hours, I can notice around 70-80% CPU utilization.

    I tried everything (hidden behind CloudFlare, check access log etc) but clueless of what to do. Disabling plugin is not an option for me.

    Thanks

  • Dimitris
    • Support Star

    Hey there Rohit,

    I’m afraid that in a rather loaded WP installation with more than 60 active plugins, a theme/plugin conflict test may reveal the source of this high CPU usage. The more appropriate way to do that is to create a staging environment, meaning a complete copy of your installation in another location on the same server. You could then test things freely upon the same server setup as your production site.

    Let us know if this could be possible on your behalf!

    Could you also please download your .htaccess file, rename it to htaccess.txt and attach it here in your next reply?

    Warm regards,

    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.