HELP! Pro Site Plugin

Hi please help with Pro Sites Plugin

I have site example.com were users can go and and create sites at example.example.com. That is where I have the Pro Site plugin installed, this is set up perfectly and running 100%

Now I have created anotherexample.example.com Network and mapped it to anotherexample.com

So basically I have two Networks running from one Installation.

But now when I activate the Pro Site Plugin at anotherexample.com it resets itself.

Like when ever I select the modules it saves them, but the moment I edit and save the settings part the modules resets itself …?

Any idea?

  • aecnu
    • WP Unicorn

    Greetings minglemooch,

    Thank you for this great question and bringing this significant issue to our attention.

    Lets first dig into your network configuration which may indeed give the answer.

    From your example URLs given above you are trying to create networks on sub domains? So that a site created would be in fact subdomain.subdomain.domain.com?

    Same with the second domain?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings minglemooch,

    Thank you for your additional input.

    I am trying to figure out if you are indicating the opposite of what should be i.e. mapped domain to sub domain not the opposite way around as you indicated in your last post.

    Please advise.

    Cheers, Joe

  • minglemooch
    • Site Builder, Child of Zeus

    I have my original domain

    myoriginaldomain.com

    Then I have the ability to create more than one network cause of the Netowrks+ plugin I have

    myoriginaldomain.com is my main Network and then I created exampleno1.myoriginaldomain.com that is a second Network I added witch were the Pro Site Pluggin is working perfectly

    Now I made another Network exampleno2.myoriginaldomain.com and mapped that domain name to myoriginaldomain.co.za And this were the Pro Site plugin resets

    Hope this explains it better

  • aecnu
    • WP Unicorn

    Greetings minglemooch,

    Thank you again for the additional input and clarification, it is truly appreciated.

    Then I have the ability to create more than one network cause of the Netowrks+ plugin I have

    I cannot vouch for the Networks+ plugin nor could I find it I find it in the WordPress repository.

    However, I can indeed vouch for the Networks for WordPress plugin which I use heavily and to date has worked flawlessly.

    In addition there is no need for Domain Mapping in the way that you are using it as you mentioned above.

    exampleno1.myoriginaldomain.com that is a second Network I added witch were the Pro Site Pluggin is working perfectly

    Which in my opinion will clearly be a challenge to get working because you are indeed building sub domains on sub domains. i.e. When I create a site on the exampleno1.myoriginaldomain.com Pro Sites installation the site will be something like site1.exampleno1.myoriginaldomain.com – or am I still misunderstanding what is going on here?

    Now I made another Network exampleno2.myoriginaldomain.com and mapped that domain name to myoriginaldomain.co.za And this were the Pro Site plugin resets

    Once again this indicates sub domains on sub domains. Not recommended.

    I would recommend setting up your network with Networks for WordPress plugin and adding the second domain to the network of networks which does not require domain mapping as a separate plugin.

    I think in the short and long run you will be much happier with this configuration.

    However, the choice is yours and if you want to continue on the path you are currently trying to work, I will see if I can get the lead developer in here to provide his invaluable advice and insight on how to overcome the issue you are currently experiencing with your current configuration.

    Please advise.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.