Help to configure multisite permalinks (pretty urls)

I've setup a fresh WP (v 3.9.1) installation to multisite and started working with Domain Mapping and Multi Domain plugins. I can access the created sites without problem, but any pages within them are not accessible (I get a 404 error). Example:

sites.bizconsult.com.br works ok
sites.bizconsult.com.br/pagina-exemplo/ doesn't work (which is a page inside that site).

What am I doing wrong?

Thanks,

Elvis

  • Dharmendra
    • The Incredible Code Injector

    Hello @elvisfernandes,

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Please make sure that you have followed all the steps from here:
    https://premium.wpmudev.org/manuals/wpmu-manual-2/creating-a-network-to-enable-wordpress-multisite/ and configured the configured the permalinks via WordPress Admin area ==> Settings ==> Permalinks correctly.

    Please make sure that you have added the generated mod_rewrite rules to your .htaccess file, replacing other WordPress rules.

    If you still face the same issue, then could you please grant the support access via the WordPress Dashboard >> WPMU DEV Dashboard >> Support >> Staff Access >> Grant Access. So that I can take a closer look on it.

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here: https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thank you for being a WPMU Dev member!

    Have a great day!

  • elvisfernandes
    • WPMU DEV Initiate

    @Dharmendra, thanks for your response. I figured it out: I forgot to enable mod_rewrite in Apache. My bad!

    (Forgot to mention: I'm running Apache under a Ubuntu micro instance at AWS)

    sudo ln -s /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled/rewrite.load was enough to fix the problem.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.