Help with Payflow Pro Problems

Hi!

I am integrating Paypal Payflow Pro and everything is going well except when I checkout it says:

User authentication failed

I looked at your forum post

https://premium.wpmudev.org/forums/topic/marketpress-payflow-pro-not-sending-info-to-paypal

And

https://premium.wpmudev.org/forums/topic/paypal-pro-user-authentication-failed-on-credit-card-confirm-payment?replies=2

And it doesn’t look like what I am experiencing. I have double checked that my Vendor/Pwd/User are all correct and even called paypal to see whats happening and they were unable to assist me. The SSL is working correctly. Can you help me figure out whats going on?

Here is the default store page

https://www.grecosurfboards.com/store/

Products Page (For test purchases)

https://www.grecosurfboards.com/store/products/

Shopping Cart Page (I haven’t put a link in the header yet)

https://www.grecosurfboards.com/store/shopping-cart/

Thank you for your time!

  • Timothy
    • Chief Pigeon

    When I try and checkout on your site and enter some random card number it just refreshes and doesn’t tell me anything.

    That might be because I’m not entering real card details but would have thought it would have indicated the error somehow.

    This gateway is still in beta and not one I use myself so it’s hard for me to know for sure. But lets try a couple of things:

    Check if you have transaction password enabled. log into PayPal Payflow Pro and click:

    Account Administration –> Manage Security –> Change Password.

    If there is a link to “Change Payflow Pro Transaction password” then it would seem you have a different password to that which you log in with. Please try that one in the MarketPress admin area.

    On Paypal Payflow when you login look for “Service Summary” whats it say?

    And finally check for Allowed IP addresses:

    Account Administration –> Manage Security

    There shouldn’t be an IP address there, if so then please change that.

    Let me know if that helps.

    Take care.

  • TGrec17
    • Flash Drive

    Hi Timothy!

    Thanks again for helping me.

    The paypal guy doesn't see anything either, when I checkout it there is an error, perhaps because I am logged in as the wordpress administrator? I have attached a screenshot for you to see.

    Here are the responses to your questions:

    If there is a link to "Change Payflow Pro Transaction password" then it would…

    There is not a link to "Change Payflow Pro Transaction Password" There is a link that says "Create separate password for PayPal Manager"

    On Paypal Payflow when you login look for "Service Summary" whats it say?

    PayPal Payments Pro Live —

    Hosted Checkout Pages Live —

    Payflow SDK/API (Full Access) Live —

    Paypal Express Checkout Live —

    There shouldn't be an IP address there, if so then please change that.

    There is nothing in either "Allowed IP Addresses For Manager" or " Allowed IP Addresses For API"

  • Timothy
    • Chief Pigeon

    hmmm, the User authentication failed error I believe is a Paypal one…

    I see the following information:

    User authentication failed. Error is caused by one or more of the following:

    Invalid Processor information entered. Contact merchant bank to verify.

    “Allowed IP Address” security feature implemented. The transaction is coming from an unknown IP address. For more information, refer to Allowed IP Addresses.

    You are using a test (not active) account to submit a transaction to the live PayPal servers. Change the URL from pilot-payflowpro.paypal.com to payflowpro.paypal.com.

    From:

    http://www.paypalobjects.com/en_US/vhelp/paypalmanager_help/result_values_for_transaction_declines_or_errors.htm

    Can you reset the IP thing, turn it off?

    If not then I’ll ask Aaron our dev on this plugin if he has any other ideas he could share. But that’s pretty much what Paypal tells us.

    Take care.

  • TGrec17
    • Flash Drive

    Hi Timothy,

    I have written paypal to see if it is the Allowed IP Addresses that is causing the headaches.

    How can I be sure that marketpress is using payflowpro.paypal.com instead of pilot-payflowpro.paypal.com? I have double checked that “Live” is selected in the payment settings of the shopping cart.

  • Timothy
    • Chief Pigeon

    When using Live it should be using their live site.

    If you wish to look at the code:

    /marketpress/marketpress-includes/plugins-gateway/payflow.php

    if ($settings['gateways']['payflow']['mode'] == 'sandbox')	{
    $this->API_Endpoint = "https://pilot-payflowpro.paypal.com";
    } else {
    $this->API_Endpoint = "https://payflowpro.paypal.com";
    }

    So it checks to see if it’s in sandbox and if it is then uses pilot-payflowpro and if not then uses the payflowpro one.

    If you wanted to be totally certain then you could edit that to just have this:

    $this->API_Endpoint = "https://payflowpro.paypal.com";

    Then it can only return that. But I don’t think it would be necessary.

    Let me know what they say?

    Take care.

  • TGrec17
    • Flash Drive

    Ok, I solved it with the help of paypal.

    I had a exclamation point in my password that was not being urlencoded correctly by marketpress. I removed the exclamation point from my password and now it works like a champ!

    Thank you so much for your help. This will probably be useful to other people as well.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.