Help with render blocking wpmucdn js files in Hummingbird

Hello,

I am seeing this in Hummingbird’s “Remove Render Blocking Resources” section:

Remove render-blocking JavaScript:

https://hb.wpmucdn.com/mydomain.com/0c541e84-3719-4b75-91a0-f3efbb2cf1b2.js

https://hb.wpmucdn.com/mydomain.com/92986271-0243-4159-9626-610bbda55aeb.js

https://hb.wpmucdn.com/mydomain.com/78c0c2db-608f-4ba8-afb9-36ff93107535.js

I’ve turned on caching and tried to get it to use Cloudflare. I’m not sure A) why there are still some pointing at the wpmucdn and B) why these have been configured to render block. Seems like anything Hummingbird does should avoid causing issues for Hummingbird to complain about. Please advise. Other than this, I really love Hummingbird. I just want to get it running as fast as I can and I’m sure we can figure this one out together.

  • Neel Gajjar
    • Staff

    Hello David,

    how are you doing today?

    I checked your site on PageSpeed Insights, there are few files in Render Blocking Resources.

    I've turned on caching and tried to get it to use Cloudflare. I'm not sure A) why there are still some pointing at the wpmucdn

    Are you still using WPMU DEV CDN? I would request you deactivate WPMU DEV CDN first, so it doesn't conflict with CloudFlare CDN network.

    Also, I can see that Hummingbird caching is enabled on your site and this might be affecting Cloudflare

    Check the image on how to deactivate WPMU DEV CDN in Hummingbird.

    B) why these have been configured to render block. Seems like anything Hummingbird does should avoid causing issues for Hummingbird to complain about. Please advise.

    You might have combined CSS/JS files under Hummingbird > Asset Optimization so it has generated above-mentioned files. These are the files which are loaded in above the fold area (the area which you see before you scroll down). Now Hummingbird is reporting those files in a performance test is because Hummingbird uses Google PageSpeed Insights API for testing the page.

    To eliminate Render Blocking issue you can find a detailed guide on it is given below link:

    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    However, it is important to remember that it's not always possible to eliminate all the files as it might break your site, the ultimate goal is to lower the number of files.

    Note this is a trial and error process, sometimes shifting or combining few important files might break the site. So it is advisable to first perform it in a staging environment.

    Hope this helps, we'll be looking forward to hearing back from you.

    Kind regards,

    Neel Gajjar

  • David Thibault
    • The Incredible Code Injector

    When I go into Hummingbird Pro, and click Settings, there's only one setting and that's for Color Accessibility. See the attached image.

    I also just deactivated CloudFlare under the Browser Caching page and still those WPMU CDN settings did not come back under Settings (I was hoping they would). It still just shows "Color Accessibility" only.

    I'm using Hummingbird Pro 1.9.4.1. Please advise.

    I have not combined any files under the Asset Optimization. I have compressed them all (at least the ones it would allow me to compress without warning that they were already compressed).

    Also, I find it strange that the Browser Caching apparently uses CloudFlare and not Page Caching. The browser caching should be setting the visitor's browser to cache locally, and the page caching should be going to Cloudflare, shouldn't it?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.