here I am again :), this time with a problem concerning

Hi, here I am again :slight_smile:, this time with a problem concerning iDeal Payments.

I've added some variations to my products, but when trying to pay with iDeal it says the hashcode validation was not successful.
After some testing I've narrowed it down to a problem with the product title. When adding a variation the title is displayed as: productname:variation. The":" is what creates the problem.
Is there an easy (and permanent) way to change this to for example "-" ??

Thanks in advance!

Cheers,
Jolanda

(http://www.arte-dal-fiume.com)

  • Vinod Dalvi
    • WP Unicorn

    Hi Jolanda,

    Thanks for posting on the forums and sorry to hear of the problems you are having.

    Could you please share me the page link on your site to test it?

    After some testing I've narrowed it down to a problem with the product title. When adding a variation the title is displayed as: productname:variation. The":" is what creates the problem.
    Is there an easy (and permanent) way to change this to for example "-" ??

    Is it working if you change the ":" to "-" ?

    Kind Regards,
    Vinod Dalvi

  • Jolandak
    • Site Builder, Child of Zeus

    Hi Vinod,

    You should be able to see what I mean when visiting my shop (http://www.arte-dal-fiume.com) and adding a product to the cart. For example: http://www.arte-dal-fiume.com/store/products/bord-vierkant-20-x-20-cm/.
    This is a product with variations. The : is placed in the title by MarketPress. So it's not something I manually placed in the titles.

    I have tested several products with for example numbers or - in their title and it worked just fine. Only the ones that have variations and therefore a : in the title give this issue.

    I hope this helps you solve my problem :slight_smile:

    Thanks,
    Jolanda

  • Vinod Dalvi
    • WP Unicorn

    Hi Jolanda,

    Thank you for your reply.

    I have tested it on your site with adding this product http://www.arte-dal-fiume.com/store/products/bord-vierkant-20-x-20-cm/ and paying with iDeal Payment. I have redirected to the bank with proper product information. I didn't pay to complete the transaction.

    Could you please tell me on which checkout step you are getting "hashcode validation was not successful" message and share me the screenshot of it if you can?

    I want o reproduce this problem on my test site so that it can be resolved.

    Best Regards,
    Vinod Dalvi

  • Jolandak
    • Site Builder, Child of Zeus

    Hi Vinod,

    I'm not sure what's going on, but the problem seems to have disappeared...
    I tried the same thing I did 2 days ago but I'm not getting the error message anymore.

    Could it have been a problem at my bank? They must have solved it then...???

    Anyway, I'm sorry to have taken up your time! Thank you very much for your help!

    Best regards,
    Jolanda

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.