Hidden page is showing up as page not found

How do I get a page not to show up under my tabs but available to the public if they enter the url.

I want to redirect those that use the cancelation shortcode in appointment plus to a web page that says that their cancelation is confirmed. however if I create a private page and enter the url when I am not logged in to WP it shows up as "not found".
this is my hidden page: http://www.hlsched.com/reflex/cancel/
i have enabled support.
thank you,
matt