High CPU Usage after Hummingbird update

High CPU Usage once the Hummingbird plugin was updated to the latest version of v 1.0.8.2 in the Multisite. Could notice the following log in Apache when the command is executed:

the error capture is log by apache
tail -f /var/log/apache2/domlogs/siteURL.com

Apache Logs:

"HEAD /?wphb-check-cf=true HTTP/1.1" 200 - "http://siteURL.vn/?wphb-check-cf=true" "WordPress/4.9.4; http://siteURL.vn

Please check the chat notes for more info about the logs.

  • Kasia Swiderska
    • Support nomad

    Hello Henry,

    I'm sorry for the inconvenience caused by the plugin. We have couple of reports after the recent update like yours and that seems like a bug :slight_frown:
    Our developers are notified about the problem and they are investigating this issue to provide a fix.
    As soon we will know more we will post here more information.

    kind regards,
    Kasia

  • John Roeland
    • WPMU DEV Initiate

    Same here. We have a workaround that seems to work for now. We disabled the WP_CRON and setup a cronjob every 30 minutes to run the script wp-cron.php in the root directory.
    It looks like that slowed it down quite a lot.

    The wp cron executes every time a page is loaded. Seems like Hummingbird is checking the page constantly causing this script to run.

  • JaqsMale
    • New Recruit

    I also had issues on a multisite and have had to delete the Hummingbird plugin as I was unable to inactivate it. When logged in to my site, and viewing the home page, I received an error message:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 256 bytes) in /homepages/18/d321883701/htdocs/wp-includes/meta.php on line 837

    Also the site was just showing a cached version not the latest images, posts or updates.

    Thanks for fixing this.

    Jacqueline

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.