High CPU usage troubleshooting error code

I have had a recent extremely high CPU usage causing a restriction on my hosting account. The support team sent me a list of some of the causes. The URL below shows only one hour of the error message. Apparently, my site was "calling itself" in their language. There were four hours of high usage, but I didn't see more than what's in this URL report.

http://spam.hgfix.net/5374615.txt

I am currently on a shared server and I know that's not sufficient for a multisite. I am in the process of upgrading to a dedicated server.

In the meantime, I'm trying to figure out what is causing these crazy high spikes so I can eliminate them from affecting my new dedicated server.

Thanks for your help.

Joe.

  • Sajid

    Hi joejacobson,
    Hope you are doing good today :slight_smile:

    I am sorry but I don't think we can determine what plugin or resource is causing this spike since in the log there are no reference found.

    I can see you are using Post Indexer plugin, that requires a good amount of server resources to index data from all of your sites on network.

    So first of all deactivate it and if you still don't get any idea then you need to do a plugin/theme conflict test as described in our getting support manual.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • joejacobson

    Thanks for looking. I deleted the Post Indexer since I really wasn't using it.

    I already did the plugin conflict test and found that WP Supercache was causing the automatic download of .gz problem (I put in a separate ticket for this).

    I still haven't resolved my high cpu spikes, but I'm going to mark this as resolved. I am upgrading to a dedicated server, so that should help.

    Thanks, Joe.

  • Nastia

    Hello joejacobson , I trust you are doing well today!

    I've checked the debug.log you posted above and it mostly shows the redirect bots request from http://www.domain.com to domain.com

    I still haven't resolved my high cpu spikes, but I'm going to mark this as resolved

    As for CPU spikes, how many plugins you have activated on your site? You need to start deactivating plugins to find the one that causing this CPU spike.

    Install P3 Profiler plugin to identify which plugins are slowing down your site:
    https://wordpress.org/plugins/p3-profiler/

    I hope this helps!

    Cheers,
    Nastia

  • joejacobson

    <ifModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A86400
    ExpiresByType image/x-icon A2592000
    ExpiresByType application/x-javascript A2592000
    ExpiresByType application/javascript A2592000
    ExpiresByType text/javascript A2592000
    ExpiresByType text/css A2592000
    ExpiresByType image/gif A604800
    ExpiresByType image/png A604800
    ExpiresByType image/jpeg A604800
    ExpiresByType text/plain A604800
    ExpiresByType application/x-shockwave-flash A604800
    ExpiresByType video/x-flv A604800
    ExpiresByType application/pdf A604800
    ExpiresByType text/html A900
    </ifModule>
    <ifModule mod_deflate.c>
    # compress text, html, javascript, css, xml:
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    </ifModule>

    # BEGIN WPSuperCache
    # END WPSuperCache

    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>

    deny from 104.217.242.133
    deny from 193.201.224.128
    deny from 104.194.4.96
    deny from 195.154.235.55

    # BEGIN WordPress

    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # END WordPress

  • Nastia

    Hello joejacobson

    There are no redirect rules in your .htaccess file. So the redirection coming from a plugin or from the WordPress itself.

    Usually SEO plugins have settings for canonical url.

    Please note the following:
    - If you have a multisite with the subdomain install, then you cannot this behavior at all, the www is a subdomain.
    - If you have a multisite with sub-directory install and want all the sites to be www, then edit your wp-config.php and change the DOMAIN_CURRENT_SITE to be your www domain.
    - If you are using Domain Mapping, then use the domain mapping plugin to change the domain to have a www in it.

    I hope this will help!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.