High GPU usage incurs exstra charges

Getting charged from the hosting provider regarding high GPU Usage spike in the past month. Hosting provider is pointing to plugins like Defender and Hummingbird which is causing the issue, as they investigate this further.

Please advise what could be done to correct this. Please check chat notes for more info.

  • Adam Czajczyk

    Hello stripedrhino

    I hope you're well today and thank you for your question!

    I have checked your chat and the site and I think the issue here might be a bit more "tricky". Some of our plugins that your host pointed to are indeed a bit "resource hungry" (which is a consequence of what they do/what they are supposed to do) but the site itself is not that complex and I understand that the host is a some sort of "cloud hosting" so I wouldn't expect that much of a resource consumption there.

    Unless the instance that you're using is really simply if it comes to allocated resources, but I'll assume for now that it's not :slight_smile:

    I would definitely recommend starting with switching to PHP 7, at least on the sites that were identified by host as the most "resource heavy". That alone should give a boost to performance and lower resource limits. Most hosts let you revert back if anything goes wrong but I think nothing should happen (though it's always good to have backup, just in case).

    Another thing worth changing: on a site that I checked (the "lesleylogandpilates") WordPress is set to be allowed to use up to 1024M of memory - which equals the memory allowed for PHP on a server. While that might sound like a good idea, it not always is. Certainly 40M allowed with default WP configuration would be way to less but on the other hand allowing to consume everything when there are other live sites on the same server might sometimes lead to troubles. I'd recommend actually lowering it to 512 or even 256 - but you might just experiment to see which of these values work well for you.

    You should find this line in the "wp-config.php" file of your site

    define('WP_MEMORY_LIMIT', '1024M');

    so just adjust that value to 256M and if that causes other issues to 512M.

    Then, I think it would be worth to check sites' traffic stats and make sure that "Managed Backups" (of Snapshot), "Seo Checkups" (of "SmartCrawl") and "Scheduled Scans" (of "Defender") are set - on all sites where they are enabled - to be run in the time of the day and week when the traffic to given site is lowest. You might actually also want to e.g. set Seo Checkups frequency to even lower (e.g. Monthly).

    It would also be good to enable caching on site. I see that you got Hummingbird installed but Page Caching feature is disabled - page cache also gives a significant boost to site performance while lowering resource usage at the same time.

    Finally, after checking that massive error_log (yes, I was able to open it), I found out that there's other site (theomitone) that seems to generate a lot of errors related to WordFence Firewal (WAF) and that might affect overall performance of everything as well so it would be good to check its configuration.

    Give it a go please and let's see what happens then and how that affects resource usage.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.