Hitting enter creating error; and loading gif

Hi all

Loving your support and the Buddypress. I have only two bugbears now to do with the Activity Plus module. These are

1) When I enter a URL to upload (video or link), if I hit enter afterwards instead of embedding the URL it returns an error. Instead I have to hit preview and wait. But this is not intuitive and user-friendly.

2) Now when I am waiting for the URL to embed (after hitting preview), there is nothing to show that it is actually embedding. Sometimes this can take a long time and it looks like the website has broken, or not actually done anything at all. It would be really useful to show a loading gif so that the user knows that something is happening.

Please can anyone help me resolve these two issues? I will be eternally grateful!

Thanks

Rob

  • DavidM
    • DEV MAN’s Mascot

    Hi Rob,

    Thanks for your feedback on all of this. In testing, I can see what you mean about pressing Enter after typing in a url. I'm not seeing an error displayed, but the url isn't getting posted as it would with the Preview button pressed.

    You're right too, a loading graphic would be nice when loading up the preview.

    I'll ask the developer to have a look at these items regarding general usability.

    -David

  • Vladislav
    • Dead Eye Dev

    Hi,

    Both valid points. In the latest release (v1.3.1, just released) hitting "Enter" in video/link URL box will trigger the preview instead. Also, there should be a waiting image indicator while you wait for the preview. One note, since both changes are in the javascript files, you may want to clear force-refresh (Ctrl+F5 in most browsers) your activity page or clear your browser's history after the update, in case the old script got stuck in the browser cache.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.