home page overwrites another page

after a few hours of work on a page, it froze. So I closed editor and reopened. The work that I had done was gone and instead displayed all contents of my home page.
How can this happen?
Possible cause: 5 hours earlier I had tried the Content Copier plugin to copy home page to new page as starter. Content copier kept telling me it can't move on until i pick an item, which I kept doing but it would not move forward. So I quit content copier.
Could content Copier carry out a function several hours later?

  • Nithin
    • Support Wizard

    Hi Ben Smith,

    Hope you are doing good today. :slight_smile:

    Could content Copier carry out a function several hours later?

    Multisite Content copier plugin doesn't carry out functions several hours later. And from what you have mentioned you didn't complete the full steps to carry out copy form one site to another, right? If yes, I don't see any way this could have occurred through Multisite Content Copier plugin.

    Could you please mention the subsites where you are noticing this issue? I suppose it's testinggrounds? To which subsite did you try to copy using Multisite Content Copier? Is that the same site you are having issue? Did you check whether the theme settings are correct, when it comes to displaying the contents in the homepage?

    I'm being redirected to a login screen when I try to access your subsites, could you please advice what I'm missing here, so that I could check your subsite dashboard. Please do provide more details, so that we could help get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Ben Smith
    • Site Builder, Child of Zeus

    The subsite is demo.com-autoproducts.co

    I'm not sure why the redirect to login. It has been doing that to me also when I initially go from main site to a subsite. Any ideas what may be causing this?

    Wher do I check this "Did you check whether the theme settings are correct, when it comes to displaying the contents in the homepage?"

    Thanks

  • Ben Smith
    • Site Builder, Child of Zeus

    Update:

    I went ahead to start redoing the page demo.com-autoproducts.co/car-care page (this is the one that was over written with home - demo.com-autoproducts.co).
    On the car-car page I changed the header region image to a solid color and saved. Out of curiosity I went back to check home page and the header region was also changed to the solid color.

    So what ever editing gets done on car-care will automatically edit the home page.
    Hope this helps

  • Ben Smith
    • Site Builder, Child of Zeus

    Tried the reverse. Editing the home page does not change car-care page. Infact after editing and saving on home nothing really saves. If I leave and return to home no editing was saved.

    Also once I go to another page and then want to return, I click on post/pages but I cannot find the home page that was built in upfront. To get back to home I have to close upfront or click back arrow on browser. Should it be this way?

  • Kasia Swiderska
    • Support nomad

    Hello Ben,

    I can't check why home page is not saving any changes because there is still that redirect. Without Domain Plugin it should not do that.
    My suspicion is that one of the plugins you have on site is causing that. Please run a quick plugin conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    On the car-car page I changed the header region image to a solid color and saved. Out of curiosity I went back to check home page and the header region was also changed to the solid color.

    You edited global region. Global regions are the same on each page where they are placed. If you change it on one page, it will be changed globally.

    Editing the home page does not change car-care page. Infact after editing and saving on home nothing really saves. If I leave and return to home no editing was saved.

    There is very probably error in browser console that prevents saving. I can tell more when I see error myself or you can check it https://developer.chrome.com/dimage_classevtools
    and let me know whats inside.
    Now I can see that plugin WP Sticky Menu is throwing JS error in console on front end, so it might be also worth to check saving while doing plugin conflict test.

    Also once I go to another page and then want to return, I click on post/pages but I cannot find the home page that was built in upfront. To get back to home I have to close upfront or click back arrow on browser. Should it be this way?

    Yes. Except that you can load home page by clicking Upfront logo in Editor

    This is because Home page is virtual page.

    kind regards,
    Kasia

  • Ben Smith
    • Site Builder, Child of Zeus

    Thanks for the Info.

    On the issue with "any changes to car car page changes home", it is with any non-global region.
    Even if I open and save car care and there are any differences between it and home, home will change to match the car care, global or non-global
    I would delete this car car page but worried home will delete also?

  • Ben Smith
    • Site Builder, Child of Zeus

    Ok I deactivated all plugins and then got error "can't access this page" and could not log in to dash board.
    So I renamed plugin folder in cpanel and was able to login
    Then went renamed plugin folder back which of course gave me the "cant' access page" error
    Then renamed each plugin untill I was able to login again.
    the culprit was a woo-rfq-for-woocommerce.

    This also fixed the my problem of needing to login on each site even as super admin. So I believe you will be able to access now.
    After the renaming of plugins I was getting a line error code when opening Upfront. It was a line on a plugin called AG Custom Admin, so I uninstalled it. And Upfront opens now.

    I still have the duplicate page content problem, the problem page I renamed as car-care22.
    Which after deactivating all plugins the problem persist
    I will leave the page so you can take a look

  • Ben Smith
    • Site Builder, Child of Zeus

    Ok this is crazy. I am editing the woocommerce checkout page. Clicked the undo button and the whole page tuned into my home page contents.
    I left the page without saving
    So I went to testimonial page which I haven't edited yet clicked the undo button and and it adds all my home page contents. Although this time if I edit the page it doesn't appear to change the actual home page

    This happened with all other plugins deactivated

    Please help , you have access

  • Nithin
    • Support Wizard

    Hi Ben Smith,

    Hope you are doing good today. :slight_smile:

    Even if I open and save car care and there are any differences between it and home, home will change to match the car care, global or non-global
    I would delete this car car page but worried home will delete also?

    Not sure whether I get you. If it's a non-global region in car care page, the changes made won't show in your homepage.

    I checked your page: http://demo.com-autoproducts.co/car-care/ However, I wasn't able to replicate the issue in your website, I edited a non-global region, and I don't see any changes being made in your homepage. If you still have issue, could you please mention the region on which you are noticing this?

    Deleting a page will only delete the settings/configuration related to that page, it won't alter any changes in the homepage.

    I still have the duplicate page content problem, the problem page I renamed as car-care22.
    Which after deactivating all plugins the problem persist
    I will leave the page so you can take a look

    Not sure whether I'm following you, is it the same issue, as mentioned above ie editing with global, and non-global you are seeing the changes in homepage? If not, could you please explain this issue further.

    Ok this is crazy. I am editing the woocommerce checkout page. Clicked the undo button and the whole page tuned into my home page contents.
    I left the page without saving

    I tested this with the latest version of Upfront(1.7), and I wasn't able to replicate this in my system. Could you please update Upfront to the latest version, and check whether you are able to generate this issue in your system. You can update Upfront, under WPMU DEV > Themes

    Please let us know how that goes, and advise if I'm missing out anything, so that we could help get this sorted asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Ben Smith
    • Site Builder, Child of Zeus

    Ok updtaed upfront.
    I no longer get the problem with the redo button.
    The over written page (car-care22) is still connected to the home page though. Any changes to it will alter the home page. With this in mind I'm afraid to delete it, thinking it may delete home page or it's contents.

    Id there away to backup just the home page so I can delete the car-care22 page

  • Kasia Swiderska
    • Support nomad

    Hello Ben,

    I'm sorry for delay on our side! Can you again enable support access to your site? I want to check that issue with duplicated changes from one page to home page.

    Id there away to backup just the home page so I can delete the car-care22 page

    No, not really, you can backup database where the all settings for theme and changes you made are kept.
    You can use our Snapshot plugin to make backup https://premium.wpmudev.org/project/snapshot/

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Ben Smith,

    I'm afraid, I'm not able to login to your mentioned subsite, I'm being redirected to a login screen:

    Since, it's a live site, I didn't perform any conflict test, I don't see the previous mentioned plugin being activated, so it could be some other plugin. Could you please give a look at this, and see whether any plugin is causing this issue, so that we could help get this resolved asap.

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Ben,

    Can I somehow get you user and password outside of this ticket system so you can login?

    Yes you can. When you enable support access there is field for message - you can leave credentials to that subsite there and we will see them when we use support access.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Ben Smith,

    Hope you are doing good today. :slight_smile:

    Thank you for enabling support access, I checked your page /carecare
    http://demo.com-autoproducts.co/carcare/

    And I could see the issue, it seems like you 1st created the region as Global Region, and then localized the region. However, I tried to replicate such setup in my system, but I'm not able to reproduce the same issue, it seems like the your region is still being treated as Global Region, and hence the changes made in your /carecare page, is being reflected into your homepage.

    You can definitely delete the page /carecare, it'll not remove any settings, nor any regions from your homepage. If you still think that deleting the page will cause issue, once you delete the page, it'll move the page to trash. Once done, if you still find anything missing from your homepage, you can restore the page back from the Trash.

    Do you notice the same issue with editing the regions appearing in your homepage, with any other page, other that /carcare? If it's only limited to /carcare page, and since you intention is to delete the page, the deletion will work fine, and won't hamper the homepage.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.